Hi, I'm hoping y'all can help me with a trick...

references
(Leah Hoogstra) #1

Hi, I’m hoping y’all can help me with a tricky problem I seem to have stumbled into. I have a parent Table A, child Table B, and a grandchild Table C in my app, all related to each other. The main view for this app is the detail view for Table A, where a user can get a lot of information about each Table A record in one glance. To facilitate this, I have a read-only slice of the grandchild Table C and a virtual column on Table A which is used to show Table C’s values directly on the detail view of Table A. This works well, but I want the read-only view to be sorted descending by row order, rather than the default ascending. I can’t seem to find anything that affects the sort order for the TableC_Inline view on TableA_Detail.

I’ve tried changing the sort order on the referenced view in TableA_Detail by chaning it on TableC_Inline and by adding SORT() around the REF_ROWS() function that creates the view. Neither has worked. Sorting the TableC_Inline view corrects the sort order only for the inline view on TableB_Detail, not TableA_Detail. The read-only version of the TableC_Inline view doesn’t seem to have a name or an object I can find in the app. When I navigate to this it, no view name appears in the app header; it just goes back to the app’s name.

Are there any other places in the app where I might be able to affect the sort order for this view? Or, any other ways I could get the most recent TableC information to show up as read-only on the TableA_Detail view?

(Aleksi Alkio) #2

Do you have any other table view from your TableC where the position is set as “Ref”?

(Aleksi Alkio) #3

And if you open that inline view from the View(x) button, you should see the correct view name from the emulator and then it should be easy to understand what view it’s using.

(Leah Hoogstra) #4

@Aleksi_Alkio This is the only place in the app where I have this view. When I open it from View(x), the name at the top (which usually shows the view name) just goes back to the name for the app.

(Aleksi Alkio) #5

Check the view name from the emulator and from the lower left corner.

(Leah Hoogstra) #6

@Aleksi_Alkio Thanks. In the lower left corner it says “fastTable” for the view name. There’s no view by that name when I search for it under UX. I’m not sure what you mean by the emulator though, could you clarify?

(Marc Dillon) #7

I think you need to copy the tableC_inline view, and point the new copy to the tableC slice data, since that is what you are actually displaying in tableA. Then you should be able to modify the view settings for the tableC slice _inline view.

(Leah Hoogstra) #8

@Marc_Dillon Oh my word that was so simple! Yes, that worked perfectly! Glad to finally notice the copy and delete functionality for Inline views. Thank you!

(Marc Dillon) #9

Awesome! I asked a question just the other day that had the same solution. Credit to @Suvrutt_Gurjar. Just glad I could pass it along.