Hi! I'm using a column that needs a spreadshe...

(David Suescun) #1

Hi! I’m using a column that needs a spreadsheet formula.

When i first created the App the formula was wrong, but i didn’t catch it only until later. I’ve fixed it now, but Appsheet won’t refresh the spreadsheet formula in the “SPREADSHEET FORMULA”

definitions, so all the new record have the formula with the errors.

How can I force Appsheet to refresh the SPREADSHEET FORMULA in the definitions?

So far I’ve tried: - Regenerating (at least 10 times) - Deleting the column, then regenerating to “capture” the delete, then add it again, then regenerate.

That didn’t work.

I really don’t want to delete the table and re-add it because I would have to re-work all the things I’ve customized so far.

Any help is appreciated, thanks!

David S

(Dinh Nguyen Nguyen) #2

@David_Suescun Hi David, how did you change the formula in the spreadsheet? Did you change the formula for an entire column, or just in a few cells in the column? If you change the formula for the whole column, AppSheet should be able to pick up the new formula after you regenerate the table. Also, what data provider are you using (Google, Office365, etc.)?

If you need to force an AppSheet column to use a particular spreadsheet formula, you can simply delete the existing formula and put in a new one.

(David Suescun) #3

Hi @Harry ! I tried changing the formula for the whole column, but it didn’t work. I had to write in in RC

style (had to figure it out the hard way). I’m using google sheets, Appsheet failed at picking up the formula by itself :frowning:

At least it works now :slight_smile: Thanks!