Hi, One of my users cannot connect to the app...

(Yossi Oulu) #1

Hi, One of my users cannot connect to the app anymore. He is on iphone, the app is based on Dropbox. The app is stuck in login. He removed appsheet and reinstalled from the AppStore, it gives him the login screen, he enters his credentials in Dropbox, the login just stuck there forever. Nothings helps. He used to work with one App for the last few weeks, all OK. Today I sent him a link to another App to try, he clicked on installing that app and from that moment on he cannot login to this New app or to the previous App.

I tried to replicate it on my Android, I removed the Apps and Appsheet from my Android mobile and reinstalled Appsheet, I was surprised to see that Appsheet did not ask for my credentials and immediately started syncing my Apps. Probably there is some caching on the mobile. (This sounds like security hole, isn’t it??). Maybe this is also related to the problem the User has.

Do you have any idea what to do??

Thanks a lot

(Yossi Oulu) #2

We dealt with this problem for few hours now, without success. Nothing helps. We removed the App, cleared the Cache it is stuck in login when we try to connect. I sent to the user a browser link to the app to try on his mobile. This worked. But it did not ask for Dropbox login, remembered it somehow (security??). Still the Appsheet App refuse to run on that iphone (a relatively new one). No idea…

(Yossi Oulu) #3

OK, upgrade from ios 10.3 to 12 solved it

(Praveen Seshadri (AppSheet)) #4

Hmm, wierd! @Gil_Littman_AppSheet FYI in case anyone else runs into this.

(Gil Littman [AppSheet]) #5

@Yossi_Oulu About the iOS issue, did this issue effect only one user? It is a strange issue you’re describing. I’m glad it was solved by updating the OS (which is always a good idea).

As for the other issue (app doesn’t require login): In the web version, if the user had logged in to an AppSheet app before, they won’t be asked to log in when they open a different app. A good way to test it would be to load your app in Incognito mode and see that it asks you to log in. In Android native app however, when you uninstall and reinstall AppSheet it should not remember you and ask you to log in again. Is it possible that you have removed you app’s shortcut (the one with your app icon) but didn’t remove the AppSheet app?

(Yossi Oulu) #6

@Gil_Littman_AppSheet Hi Gil, it was on iphone. I am quite sure he removed appsheet and not the shortcut as he did not know how to create a shortcut. But realy I cannot tell much as it is fixed now by the upgrade. If you would like me to check something with him I can do that. Thanks a lot for all the work. Appsheet is a great product.

Yossi

(Gil Littman [AppSheet]) #7

@Yossi_Oulu Thanks for the kind words! I was talking about the issue you had in your Android device where you reinstalled the app and it didn’t ask you to login.

(Yossi Oulu) #8

@Gil_Littman_AppSheet ohh… yes sorry. This indeed happened on my device. I removed everything before reinstalling appsheet.

(Gil Littman [AppSheet]) #9

@Yossi_Oulu Ok, I’ll look into it.