Hi the app was working well but suddenly I g...

expressions
(S C) #1

Hi

the app was working well but suddenly I got this error ,screenshot of which is attached kindly help

App : Sabarimala Clinic ID : 496778

Column Name ‘Phone’ in Schema ‘Orders_Schema’ of Column Type ‘Phone’ has an invalid app formula '=[Customer Name].[Medical representative Mobile Number?] '. Error in expression ‘[Customer Name].[Medical representative Mobile Number?]’ : Unable to find column 'Medical representative Mobile Number?'MORE INFOGO TO THE PROBLEM

thanking you in advance

(Aleksi Alkio) #2

And you have checked that this “Medical…” is typed exactly the same way and you have that column name in your “Customer” table?

(S C) #3

Yes it’s the same. I have also regenerated the columns

(Philip Garrett) #4

@S_C @Aleksi_Alkio

I checked your app and table “Customers” does not contain a column with the name “Medical representative Mobile Number?”.

It does contain a column with the name “Medical representative Alternative Mobile Number?”

(S C) #5

Thanks.Its solved. Customers table was derived from a parent table using query function. Addition of a new column in the parent table caused the query to malfunction and caused all the problems !

(Aleksi Alkio) #6

Excellent!

(S C) #7

In the same app , In ‘Order Details’ Form there is a LOOKUP formula in ‘Initial value’

of ‘Quantity’ field.

=LOOKUP( [Product Id],

“Products Full” ,

“Product Id”

,

“Default Order Qty”

)

This is Fetching the data from the adjacent column “Default Order Unit”

instead of “Default Order Qty”

Kindly help. Thanking in advance.

Attaching screens hots

(S C) #8
(Aleksi Alkio) #9

You are probably looking for a syntax like… LOOKUP([_THISROW].[Product Id],Products Full,Product Id,Default Order Qty)

(S C) #10

I tried [_THISROW] also, but it’s not working. Here it’s not the problem of rows, It’s getting the value from the wrong COLUMN