Hide column header from Table View - Interactive Mode

Hi,

I would like to know how the column header, called “Name”, from the table “Folder” on this app of Interactive Mode was hidden (Link for the app).


The red arrow points to where the column header “Name” should be.


In my app, the column header is “Account” and I would like to hide it.

I couldn’t find a way to hide it and I looked at every feature related to the table “Folder” such as View, View Detail, Dashboard…

Could someone help me with this detail?
Thank you in advance!

Hi,

Under UX – > Options ->Table View

please turn off the setting highlighted below

4 Likes

It worked, thank you very much @Suvrutt_Gurjar!

There is just one exception, if I turn off this on Options->Table View, it is applied to all my Table Views. In other words, other table views that I have in my app won’t have a column header.

Would that be normal? Thanks!

2 Likes

Yes, the settings under UX --> Options are in general applied all across the app for that particular setting type.

If you wish to just hide the heading “Account” in your example in say “Dashboard” view and the view name is “Dashboard”, and you wish to dislay column headings in other views, an option is, you could use a display name expression something like below. Of course in that case , the option under Under UX – > Options ->Table View , that is mentioned above needs to be turned on.

IF( CONTEXT(“View”)=“Dashboard”," ", “Account”)

2 Likes

Hi @Suvrutt_Gurjar,

Thank you for your reply. Actually, I would like to hide the column header only in this View “Filter_Accounts” as you suggested.
I did what you have mentioned, I turned ON again the headings on UX -> Options -> Table View.

Then, on “Filter Accounts” View (type: Table), I went to Display -> Display name, and I wrote the code you mentioned:
= IF(CONTEXT(“View”)=“Filter_Accounts”," ", “Account”)

Unfortunately, it is changing the View Name of “Filter_Accounts” view from “Filter Accounts” to “Account”.
The column header “Account” remains untouchable.

As you can see, I changed the code and it indeed hides the view name:

I tried to go on Data -> Columns -> Filter_Accounts and to change from there the DISPLAY NAME of column “Account”, by writing the same code. It did hide the column header, but only in the “Filter_Accounts_Detail” (type: detail), not inside the dashboard.

Maybe I did not understand how it should be done, but if it is not possible to hide the column header on a View (only the View Name as the case/picture above), let me know and I will not stress much with that.

Thanks!

IF( CONTEXT(“View”)=“Filter_Accounts”," ", “Account”)

Please have this expression in the display name setting of the [Account] column, not in the view.

Also if your “Filter Accounts” table viewis included in a dashboard view, then please have the expression with dashboard view name in the display name of the [Account]column’’

IF( CONTEXT(“View”)=“Dashboard View name”," ", “Account”)

Perfect! It finally worked, thank you for the help and the teachings @Suvrutt_Gurjar! :sweat_smile:

Just to clarify for future questions:
I went on Data -> Columns -> “Filter_Accounts” -> [Account] column -> Display Name and I wrote the following code
= IF(OR(CONTEXT(“View”)=“Dash_BRL”, CONTEXT(“View”)=“Dash_EUR”, CONTEXT(“View”)=“Dash_USD”), " ", “Account”)

I have this “Filter Accounts” on three different Dashboards and now the column header does not appear in any of them! :+1:

2 Likes

Hi @edulk,

Thank you for the update. Well, we all keep learning from each other. Nice to know that it works the way you wish.

1 Like