Hiding and displaying Action icons

Hi team, I’m rather new to the tool and pretty sure the problems I’m having should be very easy to solve but I haven’t been able to do so myself and after one day trying (and searching the forum) I’ve decided to ask for help.

I have two Apps accessing the same Table, with the same Forms and Behaviour. As can be seen on the screen captures below one of them shows the Actions icons as desired (Aprovar and Reprovar) in a detailed view while the other doesn’t. Where should I look for the error for both to behave the same?

Screen Shot 2020-07-19 at 17.51.29 Screen Shot 2020-07-19 at 17.51.02

Also on the Map view all my action icons are shown when a location is selected and I don’t want that to happen but can’t find how to hide the icons…

Screen Shot 2020-07-19 at 17.50.07

Many thanks in advance!

Cheers

Are you using slices? If so, are the slices configured to include the desired actions? Do the slices allow the access needed for the actions to operate?

Do the actions have Only if this condition is true expressions? If so, could those conditions be affected by the view being used?

Create a deck view in the ref position for the table or slice the map view uses and configure your action preferences with that deck view.

1 Like

@steve, many thanks…you rock!

Best from Brasil…

Simon

1 Like