How anyone successfully deployed an app thru the App Store?

So I’m banging my head against the wall, trying to figure out Xcode and how to create a build for the Appstore. I got thru all the stuff that is on the AppSheet videos and site info but when it comes to the hand off to Apple Store connect and then to Xcode…I’m lost. Has anyone out there ever successfully deployed an app on the AppStore. If so, I may need to hire you…I’m at that point…

1 Like

Have you tried deploying using the Transporter application on your Mac?

If you need further assistance, feel free to send me a PM.

3 Likes

Thanks Jonathon…I’ll try it out

Hi guys,

@Bcoley did you figure it out. I am trying to upload the ios build as well.

@Jonathon I am having this issue when uploading the App Store IPA generated by Appsheet into Transporter

ERROR ITMS-90060: “This bundle is invalid. The value for key CFBundleShortVersionString ‘12.6.0.1’ in the Info.plist file at ‘Payload/AppSheet.app’ must be a period-separated list of at most three non-negative integers. Please find more information about CFBundleShortVersionString at https://developer.apple.com/documentation/bundleresources/information_property_list/cfbundleshortversionstring

When requesting the generation of whitelabel on Appsheet, a version number is requested. It says it has to match the one entered in itunes connect. I don’t recall entering any…

Having this issue now. A tutorial to publish the app from the generated whitelabel from Appsheet would be very helpful.

I finally did succeed. There’s something about having to make sure that with each time you create an ipa, you have to change the version number in Appsheet

@Bcoley nice!

I have generated the ipa file twice without success. What version number should I enter? On your side was it more than 9.1 and did you enter that version # somewhere in the Transporter before you run the verification?

Thanks!

I tried a new version number 9.3.0 and have it matched with the apple connect version. I receive the same error on the apple transporter when trying to deliver it: ERROR ITMS-90085: “No architectures in the binary. Lipo failed to detect any architectures in the bundle executable”

I updated my mac and redid the steps and the Transporter accepted the build.

1 Like

Hallelujah

Bryan Coley
Chief Creative Officer
Reel Experiences