How can i disable the SMS button?

Hey there,
I have a detail view where a phone number is automatically followed by two buttons:

  • Initiate a phone call
  • Send a text message (SMS)

These are great! But some phone numbers actually represent fixed lines and they dont support messaging. Because of this, I would like to simply hide the text messaging SMS button (for every entry).

Is there a way to do so?

The button to initiate a call should remain. That one is really useful.

Find the system-generated action in Behaviors > Actions. You might need to click on ‘Show system actions’ at the bottom.
Then choose the appropriate option in that component - see image


Awesome. It works!

Thank you! :slightly_smiling_face:

Alternatively, in the Phone-type column’s configuration, disable Textable:



Thanks @Steve . This will be very useful.


oh right!

1 Like