How do I get my emails and PDF reports to use...

(QFM Services) #1

How do I get my emails and PDF reports to use DD/MM/YYYY format?

My appsheet displays dates in the exact format I need. The Excel spreadsheet it is linked to displays dates in the right format too. However the emails and PDF reports generated through Behavior > Workflow in Appsheet use the MM/DD/YYYY format.

I have set the default language to English United Kingdom, and my computer is set to English Australia.

Is there a way to fix the formatting, or perhaps change it to DD MMM YYYY HH:NN AM/PM? Do I need to set up a Virtual field in the table and then use that on my reports and emails?

(Philip Garrett) #2

@QFM_Services

Workflow displays Date, Time, and DateTime values based on the “Localization” setting for the table. Go to Data > Tables and check the “Localization” setting for your table.

If you were using Google Sheets this would happen automatically. When you create a Google Sheet you can set its “Locale”. When you create a table from a Google Sheet, we automatically retrieve the “Locale” you specified and set the Table’s “Localization” to match the Google Sheet’s “Locale”.

Excel does not allow you to set a “Locale” for you worksheet, so we cannot do this automatically for you when you use Excel.

I am hoping that when you change the Table’s “Localization” setting it will automatically set the “Locale” for each of that table’s fields. We actually do the formatting based on the field’s Locale.

The idea behind field level “Locale” settings is that you could potentially set different Locale values for different fields within a single Record. For example, one field could use Euros and another field could use Pound Sterling. We don’t expose this at present in the Editor, but I designed it so this would be possible in future.

(QFM Services) #3

Thanks for the clarification. I’ve made the change and will test it on my work this week.

AppSheet has been great but using Excel as a data source has been very problematic. I have some VBA doing updates in the background from an unattended PC and the sync messes up regularly. I would really love to change to Google Sheets but it’s too big a job for me at the moment.

(Philip Garrett) #4

@QFM_Services

I created a simple test case this morning and confirmed that setting the Table’s “Localization” will format the values in workflow appropriately. I set “Localization” to “English (United Kingdom)” and the dates were displayed in dd/mm/yyyy format.

(QFM Services) #5

Thanks Philip. I went on the road yesterday with the app and checked the results last night and it worked just as you said it would. Thanks for your time on this one.

(Philip Garrett) #6

@QFM_Services

You are welcome. Glad it worked!

(Fabian Weller) #7

@Philip_Garrett_Appsh I’m having the same issue. But I can not fix it. Could you please take a look at it? QualityGate-622224 Workflow “Report” The columns [From] and [To] are formated in the wrong way. Thank you.

(Philip Garrett) #8

@Fabian

I attempted to reproduce the problem but I could not retrieve your workflow attachment template because your Microsoft login has expired.

If you renew your Microsoft login, I can attempt to reproduce the problem a second time.