How do I switch off this edit function on my ...

ux
(erwin blom) #1

How do I switch off this edit function on my openingspage, my dashboard view? I want this to be a view only page. Can’t find it anymore.

(Reza Raoofi) #2

Make sure the table or slice that the view is based on does not allow: Edit. It should be in the Data > Table or Data > Slices sections in app editor.

(erwin blom) #3

@RezaRaoofi Thanks, i still can’t find it. Can it have something todo with the fact that it is a Dashboard view?

(Reza Raoofi) #4

If it is in a dashboard view, then see what table/slice that dashboard view is based on, and make sure that table/slice does not allow updates.

(erwin blom) #5

@RezaRaoofi Sorry to keep on asking, but I can’t find where to switch on or off updates.

(Reza Raoofi) #6

No worries Erwin! I would be happy to help; see the screenshot below; you can disable updates on your table by switching it here; Slices also have such setting:

(erwin blom) #7

Yeah , I see it! Thanks, but not in the Dashboard view as far I can see?

(Reza Raoofi) #8

Dashboard view like any other view is created based on a table or slice, so if you open the dashboard view’s definition, you will find its table, then check that table to see if it allows updates.

(erwin blom) #9

Ah yeah, I understand, but then it would mean that all the slices bases on that table wouldnt be updatable anymore. I only want that on my homepage, the Dashboard. But if it’s all or nothing, I understand!