How do you just make a simple report now?

Now that the “automation” model is being required, I cannot figure out how to just make a simple report. Before, I could just fill out a single form and use a template and the report was ready to go. Now I seem to have to create a “bot”, then an “event”, then “processes” and “tasks”… Which I can’t get to work and they cause errors which crash the whole app, which makes me have to delete the whole thing because I can’t have the app crashing constantly while I’m trying to build a simple report which should take 5 minutes.

Right now, the issue I’m having is that it keeps telling me my Bot is not compatible with my Event, which makes no sense to me at all, since there’s almost nothing to these parts of the puzzle as far as I can tell… What’s to be “compatible” (or not)?? My feedback is that this whole thing has needlessly complicated something that was before simple, elegant and powerful.

Any help is greatly appreciated, I was supposed to have this done… Now.

2 Likes

I should add that there should be a document covering how to translate the knowledge existing authors have on reports and workflows into these new automations that are being required. I’ve searched high and low in Appsheet documentation today and I find precious little about this new stuff that’s truly helpful.

2 Likes

This often occurs when the Table or “Entity” that your Events, Process, and/or Task are set to run on are not the same. Please check those.

Here’s a short “summary” of sorts about how the new Bots relate to old Reports:

  1. A “Bot” is basically a “folder” to hold all of the components.
  2. An “Event” defines what happens in the data that should trigger the whole thing. This is equivalent to selecting a Table, selecting adds/updates/deletes/all_changes, and defining a condition expression, in the old Workflows, or selecting a time period for old Reports to run.
  3. “Process” is basically another “folder” to hold one or more steps.
  4. A “Step” is an individual action that actually occurs in the automation Bot. There are a number of new options here, in addition to running a “Task”.
  5. A “Task” is going to be equivalent to the tasks/action from old Reports/Workflows. That’s the part where you send a notification, send a SMS, send an email, send a webhook.

Hope this helps.

2 Likes

So, rather unintuitively, if you have a time-based event, if you set the process to any entity, even if it matches the entity of your task, it will crash. The entity of the process has to be set to “none”. Which is nonsensical the way it is presented. So yay, now it doesn’t crash the whole app. But it still doesn’t work. When I click run (as a test run), it processes for awhile, but I get no email. When I click monitor, this is what I see. What does the highlighted error message mean?

No clue what difference it really made, but I removed the process I created, and created a new one within the Bot interface itself (I had worked from right to left Task>Process>Event>Bot before). Now it works. The untitled “new process” the bot dialog created and the process I created separately are identical, but the one I made outside the bot dialog won’t work. Bollocks I say.

1 Like

The object reference error that you got is normally considered a bug worth contacting Support about. It’s not supposed to be an error that we can trigger ourselves.

2 Likes

Correct! Please contact support@appsheet.com for help with this.