How to find the form to edit?

In the emulator, the bottom of the screen shows the view name and the data table/slice for that view.

In this view, shown, it simply says FORM. Normally, you can click on the name and it will open the form or the table/slice referenced.

I can’t find it anywhere. In this case, I click on a record in a deck view based on the slice shown and it opens this form. I need to attach an action to this form but can’t since I can’t find it. Where can I find it? Thanks.

Screen Shot 2020-05-08 at 3.49.47 PM

I tried to create my own form based on the slice used above but get an error because the slice ONLY ALLOWS EDITS, not adds. Screen Shot 2020-05-08 at 3.55.19 PM

When it says View:Form, this is a auto generated view that does not actually exist as far as I have found. It means there is no system generated view for that table.


Does your UX tab look like this when you find that table/slice?

1 Like

YES! If it only virtually exists, where can I put an action that Changes Data, when you click save, based on the value of a certain drop down box? I got the action to work on the data entry forms based on a different slice but this ‘form’ only allows updates in very select cases.

If you create a view that uses that table/slice, that is not a reference view, appsheet will generate the system views for you. This might be what you need. Not 100% following your case but this system generated view should let you satisfy your needs. I don’t know if this not generating system views until a view that is not a reference is created is a bug or not, @Steve.

1 Like

Austin, thanks for the tip of making it a NON REF view. That did force AppSheet to create a form view. Unfortunately I get the same error I did before that the slice does not allow new entries.

@Steve How can you create a form that is exclusively for UDPATES? I guess that is what this boils down to. Obviously, AppSheet can do that but then you can’t reach it to add actions.

Custom forms should do the trick for that. I have one for my HR app.
Are you using link to form or link to row when trying to edit values?
LINKTOROW([ApplicationMatchID],“MVEForm”)
This is how I force my users to update all the necessary fields before submitting their changes.

1 Like

I’m using a deck view to select the record to edit. Then I’m using the default Event Action, Row Selected, Edit. So I guess there is where I need to do what you did? I think that may be beyond my brain capacity, at least right now. I’ll have to dig into that over the weekend. I really appreciate your help.

Is your “MVEForm” for edits/updates only? If so, how did you create it?

Looks like you’re making good headway with @Austin_Lambeth. If you two run into a roadblock, gimme another shout. What you’re trying for is definitely doable.

The slice that I use in my MVEForm is update only. This is very odd since I just fired up one of my test apps, made a deck view and set the row selected action to Edit and it worked just as intended. I suggest re-selecting the row selected action because I have noticed “old” actions being selected ie. I’ve deleted an action created a new one with the same name and the old action is the one still being used on row select. If it still does not work at that point, I would suggest making a form view and an action that links to that form view to be used as your row select.

1 Like

@Austin_Lambeth I have no idea what I changed to make it work but it is working now. I left it alone all weekend, made multiple table level column changes today and IT WORKS! I certainly don’t think I changed anything related to this issue but it IS working. Thanks for all your help.

1 Like

It be like that sometimes. I knew that should have worked so I was kinda concerned that it didn’t at first lol

1 Like

To explain what’s happening here:
When you make a change to any view in the editor, the emulator automatically switches to the view being changed, so you can see the changes in real-time (for the most part).

For Detail views, it automatically picks the very first record of the table/slice to show, for Form views it automatically picks the form for a new record to show. So since you just made a Form view for a ADD-not-allowed slice, and the Emulator is showing a Form view for adding a new record, you see the error.

It doesn’t really mean anything, since that slice doesn’t allow adds, the user would never be able to open the form as the emulator is currently showing it. You can still create the form, and if it is the only form for that slice, then it will be the form that opens when you click the edit button.

3 Likes