How to fix [sync to computer]

I have an inventory management app and when changing the quantity of a product in the app, the product title changes to say “sync to compute” and the image associated with it disappears. The product name and image come back after the app syncs to the spreadsheet. It was not like this earlier and I can’t figure out how to fix it. Thank you in advance.

Is the column’s value computed by a spreadsheet formula?

Please post a screenshot showing the message. Please also post a screenshot of the column’s configuration screen, and of its complete App formula expression (if any).

1 Like

There is a formula in there, but I have a dev environment of this app that is also using formulas and it’s not having the sync to compute message. I also tried copying all the data and pasting just the values without formulas for everything in the products and inventory tabs to test if that was the issue but it still said sync to compute even with the formulas removed.

2021-07-26 10_05_57-

1 Like

1 Like

1 Like

Perhaps these settings are not consistent between the two versions of the app?

image

I have both versions setup with all three of those sync options turned on. I’ve played around on both with turning ones on and off but the one with the sync to compute issue, it doesn’t seem to make a difference with that.

I’m afraid I have no other ideas, then. :frowning: I’d encourage you to engage Support for further help.

https://www.appsheet.com/Support/Contact

Possibly useful:

Thank you Steve. I had read that post previously and we are already using Google Sheets. I’m at a loss too. I switched my dev environment to my prod one for now until Support can take a look. Appreciate your help!

1 Like

I have a similar situation with one of my apps that tracks product orders. It happens when the view uses a field that’s calculated with a Google Sheets formula.

image

I couldn’t fix the issue but I made it easier to live with by changing some of the fields to Quick Edit. Users like this more anyways because they don’t have to switch to the full edit mode, they can simply edit the fields they want right away. In your case I suggest making the quantity field a Quick Edit column.

New user here, so take what I am about to say with a grain of salt:

Today, during the same time you reported these issues, I was having different issues. I would make changes, and then click “Save”. Ordinarily it takes 5 seconds to complete. However today, it ran for a minute or two. When it “finished” the “Save” button was still lit as though my changes never made it to the server. I checked my Internet connection…all was good. I walked away and gave it time to heal. After a couple hours, things returned to normalcy.

Brian