How to format event start/end time using a column as date?

I just need to create a event after a form saving. To do that, I created a action that add a new row to the calendar table.

In Set these columns , I need to define the Start and End columns to contain values taken from another form, I can do that without problems. The value taken from the other form is a date, I need to set a datetime for Start/End columns using that date. To achieve this I tried to create an expression that uses the date column from the first form and manually inserts the time, but the AppSheet doesn’t recognize it as a datetime.

I tried to format:
CONCATENATE([date_form_1], β€œ 08:00:00”)
DATETIME(CONCATENATE([date_form_1], β€œ 08:00:00”))
DATETIME ([date_form_1] & β€œ 08:00:00”)

Only DATETIME([date_form_1]) worked, but I can’t use the default time of noon.

This one should have worked.
I have the same formula but it takes the time value from another column instead of hard coded like yours.
You could try changing β€œ08:00:00” for TIME(8:00)

DATETIME(CONCATENATE([date_form_1], TIME(8:00)))

1 Like

It didn’t work either, same error as the others :frowning_face:

image

Error:
image

But thanks for the answer.

Please try

DATETIME(CONCATENATE([date_form_1]," ", β€œ8:00:00”))

Please note the space, " " between date and time value concatenation. I believe the Datetime column format needs a space between Date and Time values. Hope this helps.

3 Likes

Haha, that’s true!
@Henrique_Vieira add the space in the concatenation and should work like charm. In my case I have the space in the expression and forgot about it

2 Likes

Thanks! I just noticed that in the post I forgot to mention that I manually added the space to β€œ08:00:00”, I had been trying DATETIME(CONCATENATE([date_form_1], β€œ 08:00:00”)). But apparently, the CONCATENATE function ignores the space at the beginning of the string. The way you informed it worked perfectly.

2 Likes

It really worked. I had already tried to add the space to the time string, but it still didn’t work because the CONCATENATE function apparently ignores it. Putting space as a separate argument worked exactly as I needed it.

3 Likes