How to hide overlay button is made to replace "not a row level" default button in dashboard interactive mode

In my screenshot below, I created 3 different button to be replaced for Add button with some others expression under LINKTOFORM()

I know LINKTOFORM button, it is a expression for row level and we can hide or show it per view if we only want to show it at table level. But unfortunately, when I build a dashboard view, it wasn’t disappear as expression by CONTEXT(“ViewType”) because this CONTEXT() expression was recognized as “dashboard” for all table-view (not a row level) and detail-view (row level).

So I want to get help to find the way how to hide all the buttons in detail-view at the right side of my screenshot.

Please help me

Hi

If I have understood your requirement correctly, you could try the below. But please test well for your overall requirement.

Please create a slice on the table. Please ensure that the created slice has only the actions you need in the detail view enabled( For example say Edit).

Please create a detail view of this slice and please keep it as ref type.

In the dashboard view please include this slice-based detail view along with thetable view. The view level actions will not be visible in the slice based detail view.

Dashboard Actions

2 Likes

Thanks for your reply. I will try.

I understand, my issue may cause of I’m using the same table for those views. I’ll feedback the result asap.

once again, thanks alot

Ah, I can make it well. Thanks alot

2 Likes