How to make Detail View Header Uniform Font Size

,

I have a Virtual Column (longtext) that concatenates two other columns in my table to act as a label of sorts. In a detail view I have added this VC as a header column and then applied some custom formatting via a formatting rule to the VC.

Regardless of what I have tried, the header column font size changes between rows of records, seemingly increasing the font size to ‘fill (justify)’ the row(s) the header takes up depending on the character count in the header.

Is there some way to make this uniform? If not at the moment, is this something that will get addressed in the continued material upgrades?

image

image

image

I should note that I have changed the column to ‘show’ type and set it to Section Header and then inserted as just a regular column at top, however this adds unneeded space above and below the text.

Ditto! Whether it’s a VC or not, the header column always resizes itself no matter what rule you apply to it. I believe it’s because of a dynamic span ratio at the back-end.

3 Likes

Kind of a weird approach to take on something such as a header. I’m generally ok with it being able to take up more than one line of space, but dynamically stretching it on 2 planes (i.e. increasing the font size) just doesn’t make any sense to me because when using the next/previous in detail views just messes with the flow in my personal opinion.

3 Likes

Perhaps you’ll get more consistent formatting if you force the line break instead of using the hyphen.

[Before Hyphen]&"
"&[After Hyphen]
1 Like

Thank you for this suggestion. It would appear that the line break is not enforced when setting the column as a header column in a detail view.

Interesting. I don’t use headers very often, but I’m surprised to hear that it doesn’t work, since I use this LongText trick in several other places.

The detail view headers are probably treated as Text values rather than LongText values. Newlines are replaced by spaces in Text values.

1 Like