How to show a field on a list but hide it on the detailed view?

Hey there,

I need help figuring out how can I show one field on a list, while keeping it hidden on the detailed view.

For example:

I have a list of blue flowers (screenshot) and each row shows these fields:

  • image
  • name
  • stock

On the detailed view (screenshot), its showing:

  • image
  • name
  • stock
  • description
  • etc

I have another field, it’s named short description which I’ve set as hidden. As such, it doesnt appear on the detailed view and that’s exactly what I want. But because of that, I can’t show it on the list either (and this is what I would like to achieve).

Is there a work around?

Thank you.

1 Like

Hi,
Follow the same steps:

1 Like

Hey there,
Can you explain in more detail please?
I tried it but its not working.

The field I’m trying to work with is named “Short description”.
It’s currently a hidden field, as you can see on the second screenshot, it doesn’t even show. And that’s fine.

But I would like that field “Short description” to actually appear on the list view (first screenshot). Instead of the “Stock” field, i would like to have the “Short description”.

Is this possible?

  1. Select the List view in UX screen. Which will be called like Table Name_[Table|Inline] if you didn’t create it manually. If you can’t find it then go to the view on IDE and click on view name under the preview.
  2. Go View Options > Column Order and add you wish to show.

Make sure the short description column has Show? set to ON.

Find the configuration for the table view of the data table and configure the columns you want displayed:

Then find the detail view or the same data table and configure the columns you want displayed there:

See also:

1 Like

This works. Thank you!

1 Like