How to stop syncing after every save on a form

I have a form that immediately runs a visual sync after every save. I’ve played with all the syncs but can’t get it to simply save and automatically post to the google sheet in the background.; The app will run in offline mode on devices as well.

I’ve confirmed in the On Save behavior, the actions do not have a forced background sync. Can someone assist with the correct settings?

A million thanks

2 Likes

Try with this

2 Likes

Thanks Fouad, I already have the following sync set

2 Likes

With those settings, there should be no sync after saving a form. I have the same thing, and my app only syncs with my forced syncs, or someone clicking the button since I can’t get rid of it.

2 Likes

I’m not aware of any setting in AppSheet that would cause a “visual” sync after each form save, though I also admit I’ve never considered the possibility.

Do you have an Form Saved event action on the form view that forces a sync?

2 Likes

Sync should happens at the end and all the time.

Out of curiosity, do you want to make sure the sync will never ever happen? or you want to give an option to app users to explicitly select which new rows to be synced or others not to do so?

1 Like

Could you explain what you mean by

Thanks everyone, I do have an onsave grouped action in place and checked through all of the actions for a forced save type of action which I have used in the past but none contain the expression so I removed all the action re-added them one by one to see which contained the issue. I was able to re-apply all of the actions without issue and the forms are now saving as expected.

Thanks again

3 Likes

Ah, so it sounds like it may have just been a hold over from something previous and it just never got fully cleared out until you did that. So, something buggy that will need to get fixed if they can ever figure out exactly how it happened in the first place.

3 Likes