How to transfer an app?

account
(Malaka Jayawardene) #1

I tried to transfer the app I created to my other email address, I shared the gSheet, made it available in the Google drive via “Add to my drive”, reloaded the gSheet in to the app, and specified each table properly, app then loads fine, but when I try to click a button inside the app it says that The account is not authorised to access this app. Why is that?

(Aleksi Alkio) #2

Instead of transferring the app, make your new account as a co-author and then copy your app when you have logged in with this new email address.

(Malaka Jayawardene) #3

Can I make a copy of my app first and then make that new account as a co-author, so that I can keep the original with me?

(Aleksi Alkio) #4

There is no need for that… your original app will be the same than now. It will just take a copy to your new account (but you need to login first with your new account).

1 Like
(Malaka Jayawardene) #5

@Aleksi
Thank you very much!

(Malaka Jayawardene) #6

@Aleksi
I did it, copied it to the new email address, and the error didn’t come in the new app. Then I went ahead and removed the co-authorship from my original app. Then the error came back again.

(Malaka Jayawardene) #7

@Aleksi
I removed everything from the new email account and redid it. Now I get the following error.

(Malaka Jayawardene) #8

Hi Aleksi @Aleksi

I managed to copy the app again to another different email address via the co-author method. The app is now saved in that email. And that Google drive has a gSheet in it (oddly a different name has been given to it), but when I make a log entry, it still gets saved in my original gSheet, there is no entry in this gSheet. Why is that?

(Aleksi Alkio) #9

Are you sure about this? Please verify your DocID from Data > Tables and then check the spreadsheet directly.

(Malaka Jayawardene) #10

Yes. I tried several times. With new email addresses. I can’t get it to work. Once co-authorship is removed, does the app in the new email address stop working? Because that’s what happened to me. And from there onwards, no matter what I do with newer email addresses, I can’t get it to be independent of the original gSheet.

(Aleksi Alkio) #11

Would you please describe what did you do from the beginning and step by step, thanks.