I am having an issue with a dashboard view: ...

ux
(Jonathon Sinclair) #1

I am having an issue with a dashboard view:

I would like for it to be interactive. I have a parent table view and two child views (a map and a chart).

At one point it was interactive; and now its not.

In total there are 4 tables in a grandparent->grandchild flow. I also have several slices of these tables.

What should I be looking for to troubleshoot this?

(Aleksi Alkio) #2

Are these map and chart views coming from another table than the main table view? Do these tables have relationship with ref fields?

(Jonathon Sinclair) #3

Currently users create a ‘lot’, and attach ‘tickets’ to the lot as a parent-child relationship.

Based on the data collected in the ‘tickets’ record, a value is generated which pairs with a pre-generated list of ‘Bundle’ records and pkeys.

All tables have the appropriate REF fields, and they are working when adding data, in formulas, in detail views, etc.

It does get complicated in that I have a variety of slices of these tables… Maybe the problem exists here, however I have triple checked that the slices contain the appropriate ref columns (for example, I have tried having a slice for ‘lots’ and ‘tickets’ which exclude the bundles->tickets reference).

Also, I have tried recreating the dashboard without using slice views, and the interactive mode still does not work.

Really at a loss for how to get this to work again, and can’t seem to identify the point at which it stopped. i.imgur.com

(Jonathon Sinclair) #4

@Aleksi_Alkio

Currently recreating the application from the ground up from the same data… In a severely trimmed down format, the relationship and interactivity works fine again.

Will keep building the app back up and try to identify the point at which it breaks.