I am updating my app, and everything is worki...

(PBP Dispatch) #1

I am updating my app, and everything is working except for capturing signatures.

It will not sync.

Here is the error.

Any ideas?

Unable to add/edit/delete row in table ‘Permission Signature’. → { “error”: { “errors”: [ { “domain”: “global”, “reason”: “forbidden”, “message”: “Insufficient permissions for the specified parent.”, “locationType”: “other”, “location”: “parent.permissions” } ], “code”: 403, “message”: “Insufficient permissions for the specified parent.” } }

(PBP Dispatch) #2

I just tried to make it a text field, and that sync worked fine.

Not sure how to fix this

(Aleksi Alkio) #3

One of your table(s) are set as an “As app user”. Try to set them as an “As app creator”.

(PBP Dispatch) #4

unfortunately, the sheet is set as “As app creator” Permission Signature table is a slice.

There is only 1 table in the app.

Any other ideas

#5

Hi @PBP_Dispatch Is your Slice read only? New slices seem to be read only by default until you reset them.

(Eloi George) #6

Signatures are a type of Image file.

Do you have sufficient permissions on the folder storing the images?