I am working with an email template in Google...

expressions
(Green Gorilla) #1

I am working with an email template in Google Docs and having a problem with the Start Expression etc.

When the Start and End expressions are on the same row in the table, it works, but when I put the End at the end of the table it doesn’t.

I attach images to show you.

Any ideas? Does the <> have to be on the same row as the <Start:>?

First one works…second doesn’t.

(Dinh Nguyen Nguyen) #2

Hi @Green_Gorilla, to help us investigate this problem, please give us the names of the app and the affected workflow rule.

Adding @Philip_Garrett_Appsh

(Green Gorilla) #3

@Harry

The app is not just in my name, it’s someone else’s that I am added as co-author…is that ok?

Can I send details privately instead of on here?

(Green Gorilla) #4

Actually, It’s ok…I thiknk I have found a way to represent the data that works for me…

I put he Start Expression outside the table, and the END after the table, and it is working fine…

Thanks

Craig AKA GG

(Praveen Seshadri (AppSheet)) #5

Right. Actually this is by design. If you put the Start and the End in the same table row, it tells AppSheet to stamp out table rows repeatedly. However, if you put them across table rows, then AppSheet doesn’t have a sensible pattern to repeat.

(Green Gorilla) #6

@praveen

That makes sense, however,

if I want to print out, say, 20 pieces of information, for one job, and then the next 20 for a different job etc., and I want them in a landscape oriented table, I am going to have more than one row otherwise the text gets unreadable.

If I want a landscape table, split across 2 or 3 rows, I can’t do that.

(Praveen Seshadri (AppSheet)) #7

Agreed. You can have a separate table for each and split the column values across rows in that table. For that, use the <> and <> outside the table.

Or you can have a table row per data row.

The hybrid options won’t work, but they are rare.