I have a few columms where the type is set to...

(Simon Blackburn) #1

I have a few columms where the type is set to ‘Number’ (setting to Time doesnt work for me) and I have added a NumericDigits interger of 4 so my times appear as 0700 instead of 700 and this works great in my normal columns.

I have created a virtual colum to concatenate two of these colums for a start and finish time but when they’re displayed, its displays as 700-800 instead of 0700-0800.

Can anyone help me with what I’m doing wrong?

(Aleksi Alkio) #2

Modify your expression like CONCATENATE(TEXT([START]),"-",TEXT([END])) and it will work. TEXT expression saves the number column exactly the same way than you are seeing it.

(Simon Blackburn) #3

Thank you. Worked a charm.

(Aleksi Alkio) #4

You’re welcome

(Simon Blackburn) #5

@Aleksi_Alkio I’ve ran into another problem since adding a few virtual columns.

All the virtual columns I’ve added with the type ‘text’ are now showing up as read only fields on my form view.

How can I get rid of them from the form?

(Aleksi Alkio) #6

Add a simple “expression” as FALSE to Show_If. If you don’t want to hide them totally, you should change the option UX > Options > Apply show-if constraints universally > OFF

(Simon Blackburn) #7

I take my hat off to you sir.