I have added an action to my app to call my e...

(Simon Blackburn) #1

I have added an action to my app to call my employer. I have set up the number starting with to:4412345678910 but when I test the action the number to call is always 864412345678910.

Why has it got 86 at the beginning. I take this is the code to dial out of but I’m in the UK. How can I change this so it doesn’t add the 86 which I believe is China?

(Praveen Seshadri (AppSheet)) #2

Simon, is the number ‘to:4412345’678910’. I’m not sure if you actually have the ‘to:’ prefix. If so, try removing that maybe?

(Simon Blackburn) #3

I tried that and it prevents the app from working. I’ve tried 4412345678910 and I’ve tried 12345678910, +4412345678910 but the only one that doesn’t stop the app working is if I add the prefix ‘to:’.

(Praveen Seshadri (AppSheet)) #4

What do you mean “prevents the app working”. We had an issue on some Android devices where after making a phone call via the app, the app would freeze and need to be restarted. We issued a fix for that yesterday (doing a sync and then restart should fetch that fix). I think it is “to:” that is being translated somehow to the 86 prefix

(Simon Blackburn) #5

If i dont add the “to:” prefix, I get this error.

If I use “to:” the error goes away.

(Simon Blackburn) #6

I’ve worked it out. The number needs to be in quotes.

(Praveen Seshadri (AppSheet)) #7

That is ultra-odd. We do check phone numbers to see if they conform with an acceptable number. I suspect your number has too many digits and that’s why.