I haven't used my app in a month or so and now I have several error messages


Can anyone help me through these error messages? I checked that my columns on appsheet are all the same as in my spreadsheet. I’ve tried the ‘rebuild structure’ button and that doesn’t work.

First you would need to solve the mismatch issue. Please remove all blank columns from your spreadsheet and then try to regenerate the column structure again.

2 Likes

Thank you for the reply. I have checked through my spreadsheet, there were two columns which had titles but nothing in them, so I added some text in case that was causing the issue. I have regenerated the structure, but I am still getting an error message. It is also telling me my table has 84 columns but the schema has 22 columns. I can verify that my table only has 22 columns also and they match the schema, but the table goes out 84 columns total, if I keep scrolling to the left…so how come it’s trying to use all those columns when they aren’t part of the table I created? Somehow I have made those ‘active’ even though they don’t have anything in them?

1 Like

Oh wait… I see what you were saying…I just went in and deleted all those empty columns in my table and it works now. Thank you!!!

4 Likes

Excellent!