I need some help with mobile login from an iP...

(Autumn Steinert) #1

I need some help with mobile login from an iPhone.

Since the app upgrade to V2 I have not been able to log in to the app.

I also could not login to the website via my phone.

I’m running iOS 10.

I am not having any problems logging into the desktop version, and I did not have problems before the app upgrade. Now, in both cases, the “Sign in” button remains greyed out when I put in my login info (same login info I use on the desktop) Any ideas?

(Dinh Nguyen Nguyen) #2

@Autumn_Steinert Hi Autumn, let me briefly clarify how our authentication mechanism works. We rely on external authentication providers, such as Dropbox, Google, or O365, to authenticate users.

Each time you log into AppSheet from a particular provider, let’s say Dropbox, using a particular email, internally our server will “ask” this question: has this user (identified by the email) ever logged into AppSheet from this provider before? If the answer is yes, then the user is an existing user, and the server will look up the account based on the email address. If the answer is no, the server will assume that the user is a new user, and will automatically create a new account.

When you logged into AppSheet from Dropbox, our server will recognize that you are a returning user, and will retrieve your account. However, when you logged into AppSheet from another provider, let’s say Google, although you were using the same email address, because you were coming into AppSheet from a new authentication provider, our server decided that you were a new user, and thus automatically created a new account for you. Because all of your apps are currently registered with your Dropbox account, not your Google account, you will not see any apps if you log in from Google. To verify this, in desktop, try logging in from different providers (Dropbox, Google, and O365), and then open the account page. At the top of the account page, you will see that your account ID will be different for different providers.

I also see that in your Dropbox account, you have added Google and O365 as additional data sources. It’s important to keep in mind that this has nothing to do with your Google account, or your O365 account.

Back to the sigin problem using Dropbox, the sign-in page shown in the screenshot actually comes from Dropbox, not AppSheet. This might be totally unrelated, but I did notice something rather strange in the screenshot. Firstly, both the “Sign in” button and the “Sign in with Google” button are greyed out. Secondly, if you look closely, you will see that there’s a faint text that reads “Email” in the email box, and a faint text that reads “Password” in the password box. These texts appear right under the typed in email and password. These seem to suggest that there might a script error when the Dropbox page was loaded. I also found a few posts online where others have reported the same issue.

To fix this problem, could you try the following? First, log into Dropbox proper (not from AppSheet) in your device’s default web browser. If you’re using an Android device, try using Chrome. If you’re using iOS, try using Safari. If you run into the same problem in the browser, try refreshing the page, or adding and then deleting extra spaces in the email and password boxes. Once you have logged in, open the AppSheet app and then try logging into AppSheet again via Dropbox.

(Philip Garrett) #3

@Autumn_Steinert

Several of your apps do not have “Require User Authentication” set. You can fix that by going to the Security > Require Sign-In pane and setting “Require user authentication” for each of your apps.

If that does not resolve the problem, can you describe the problem in more detail and tell us which app or apps are having the problem.

(Autumn Steinert) #4

@Philip_Garrett_Appsh Thanks for the quick reply!

In the past, I would see all of my apps on the mobile app, even those without Require User Authentication.

(In fact, none should require user login.) Now I am having trouble logging into the mobile app with my DropBox login.

When I choose the DropBox option, I get the screen below-- I can enter my username and password, but none of the choices (Sign In or Sign in with Google) ever stop being grayed out.

This would be the login I use on the desktop.

If I pick a different login (say O365 or Google) I can login but nothing shows up in MyApps.

However, two apps (a navigation app and another) show up in the App Gallery from the hamburger menu.

Am I missing something?

Or did something change with the upgrade that I just didn’t catch?

Thanks again.

(Screen pic of login screen included)

(Autumn Steinert) #5

@Harry I wasn’t sure how to clear the AppSheet cache, so I uninstalled/reinstalled the app but I still get the same issue- the greyed-out Dropbox login through the appsheet app.

My last effort was to upgrade iOS (recall I was running 10.3), which was successful!

After updating to 11.2.5 I was able to sign into the app-- after the update the AppSheet app DropBox login appeared the same as for the DropBox app and login was successful.

Thanks again for your help!

And a good learning if you come across any other users with DropBox ids who are running not-new versions of the iPhone iOS.

(Dinh Nguyen Nguyen) #6

@Autumn_Steinert Hi Autumn, I’m glad the problem is now resolved. Also, thank you for patiently trying out different ways to fix this :). If other users run into the same problem, I will share your experience with them.

(Dinh Nguyen Nguyen) #7

@Autumn_Steinert Additionally, you can try clearing the cache of your device’s default browser to see if this would fix the problem.

(Autumn Steinert) #8

@Harry thanks for your help.

I may have made my question confusing confused by mentioning the other logins- my primary login is through DropBox.

I am not having an issue logging into the DropBox mobile app (logged out, logged in, no problem), but I can’t get past the “greyed out” options when logging in through AppSheet on my iphone.

Has anyone found a way past this?

(Dinh Nguyen Nguyen) #9

@Autumn_Steinert Hi Autumn, as I have mentioned, the greyed out buttons in Dropbox login page might have been caused by a script error in the page. Have you tried refreshing the page? Also, you can try clearing the cache of the default browser of the device.

(Autumn Steinert) #10

@Harry hi!

Yes, I just tried closing everything, clearing cache of the browser, and logging out of and back into the DropBox app itself.

No luck yet getting my login through the AppSheet app to work. Could this be an OS issue (I’m still running 10.3 not 11)?

Thanks again for your help.

(Dinh Nguyen Nguyen) #11

@Autumn_Steinert Hi Autumn, instead of logging into Dropbox using the Dropbox mobile app, could you try logging into the Dropbox website using the Safari browser on your device? Once you have logged into the Dropbox website using the browser, you can then try logging into AppSheet again.

(Autumn Steinert) #12

@Harry I tried a few things based on your recommendation.

(1) I tried logging into DropBox from safari- no issue, login successful. Then I opened a new tab in safari and tried logging into the AppSheet website and was successful

(2)

Then I went back to the AppSheet app- not successful logging in, same problem with the greyed out login for the DropBox login. (3)

I tried using Chrome to go to the AppSheet website and login- login successful.

So it seems that it’s an issue with the DropBox login screen that AppSheet app is trying to access in Safari on my machine?

Thanks again!

(Dinh Nguyen Nguyen) #13

@Autumn_Steinert Hi Autumn, here’s another thing that you can try. Instead of the browser, could you clear the cache and all local data of the AppSheet app in your device, and then try logging in again? If this doesn’t work, could you try uninstalling and then re-installing the app?