I'm having trouble connecting to a postgre da...

(wanderson guilherme) #1

I’m having trouble connecting to a postgre database, the appsheet gives me the following message: "Failed to establish connection. Details: One or more PostgreSQL errors were found: Can not connect to the PostgreSQL database. have been caused by temporary connection problems.Please check your connection and try again ", but my connection is working properly, can anyone help me?

(Reza Raoofi) #2

In order for AppSheet to be able to connect to database servers in the cloud, they must be configured to allow traffic from two IP addresses; see this article for details:

intercom.help - Using Data from PostgreSQL Using Data from PostgreSQL intercom.help

(wanderson guilherme) #3

yes I already configured it, but it is still presenting me with this error

(Steven Coile) #4

Do you have any other means to test connecting to your database from outside the network hosting it?

(Steven Coile) #5

Does your database log the refused connection? Or does your firewall?

(Reza Raoofi) #6

Also open your app in app editor and go to Manage section, Monitor tab, and check Audit History, see if it could indicate any more details.

Most likely either the firewall setting has not properly configured, or the credentials are not correct.

(wanderson guilherme) #7

+Steve Coile Yes I connected it to a “pgAdmin” database management system and it connects normally

(wanderson guilherme) #8

+Steve Coile No registration, just a firewall

(wanderson guilherme) #9

@RezaRaoofi but I did not present any details, for what it seems he is not even coming to the database, because even when I enter a wrong password he still presents me with the same message

(wanderson guilherme) #10

To connect to a database the plan can not be free, correct?

(wanderson guilherme) #11

I managed to make the connection, the IPs that the appSheet presented me to release access were not correct, I had to release all trafic for all types of IPs, then it made sure to make the connection. Thank you all.