Im having trouble getting text to show undern...

(Thomas Murphy) #1

Im having trouble getting text to show underneath my images in Gallery view. I have created “buttons” using the column type [APP] and this creates the pictures the button is to display. I have done this successfully in the past (Workout/Diet buttons) and those show the text underneath.

I can not re-create it though… ???

(Thomas Murphy) #2
(Thomas Murphy) #3

I have tried checking [label] under column format but it keeps resetting to unchecked

(Aleksi Alkio) #4

What happens if you use something else than APP column for that name?

(Thomas Murphy) #5

@Aleksi_Alkio The column giving the name is a TEXT column. I’ve compared with other similar working UX but this has me confused.

(Aleksi Alkio) #6

Would you please give us the account ID and app name so we can check the reason, if that’s okay.

(Thomas Murphy) #7

@Aleksi_Alkio Sure! App NAme

= DANDIET-64136 Account ID: 64136

(Aleksi Alkio) #8

I checked yoIur app and the reason is this. When you create a gallery view, the header is the key column’s value or the label column if it’s used. You are using slice for that view and the label column (Button) doesn’t belong to that slice. When the app can’t find the label column, it shows you a blank value.

I checked your tabe structure and you need to change it. You can’t use it like that if you need to have different headers for different views.

(Thomas Murphy) #9

@Aleksi_Alkio Aweome ! I kept looking at the slice too. I don’t know how I missed that. Thank You so much for finding that for me! :joy:

(Aleksi Alkio) #10

You’re welcome