Image capture trouble android device

In some android devices when capturing an image, the apps calls the camera, the user takes de photo and clicks ok, but the image is not saved.

We also are developing apps, and recently started to experience a similar, intermittent problem using an Android device camera, AWS Aurora and S3. It has arisen recently for us and coincides with (but may not be caused by) turning off the setting Behaviour > Offline/Sync > Store content for offline use. We are still investigating, but are interested to know that other people are experiencing a similar problem.

It might be helpful to know the particulars of the devices on which it doesn’t work: make, model, OS & version, whether the device has the latest AppSheet app.

Also, have you checked the affected device’s available storage? Is there room on the device to save the image?

The model giving us trouble is the 2017 Samsung Galaxy Tab A 8" 32 GB Model T380, Android 8.1.0. The device currently has 14 GB free. If the device is out of memory, how does AppSheet handle the situation? A zero length string is saved to our AWS Aurora database by AppSheet, and the corresponding file doesn’t arrive in our AWS S3. We’ve have months of trouble free behaviour with this pattern. It has just been cropping up intermittently since May 10th, around the same time we threw the switch to off for Store content for offline use.

After some investigation at our end, we’ve decided to add a column data validity test …

Data > Columns > image_url > Valid If : ISNOTBLANK([image_url])

… to guarantee that a zero-length string is not saved to the database. This will force the user to stay in the “take a picture” form until they get it right.

Our users report that the Samsung/Android camera sometimes fails to save an image, which might be at the root of our problem. Any further insight you could provide Steve would be great.

1 Like

Hi @jujogar10 @Stuart_Carmichael,
Once the user takes the photo, does a preview of the image appears in the form before it’s saved? If you could add a video capture of the issue that would be helpful.
Also, what version of the AppSheet app is running on that device?
Could you let me know the app name and which user(s) have experienced this issue? If you don’t want to disclose those details publicly feel free to send me DM or email support@appsheet.com.

Sorry for taking so long to get back to you. I am awaiting on the information from site wrt. the AppSheet version. It was installed in the last week of Apr 2019 on a fresh Android tablet for the first time. It’ll be around version 13.1 (I think). I will update this response once I’ve got confirmation.

Hi, I am just checking if this issue was every resolved for you because I am having this exact problem right now. I can capture an image from a file upload on the phone, but when I try to use the camera it doesn’t upload the image to the GDrive or App. The only thing that does upload is the file name to the google sheet. There is no actual file in the GDrive and no preview of the image in the app.

The phone is a huawei p20 with android emui 9.1.

This is the App: https://www.appsheet.com/newshortcut/313eaa22-b7f3-47ae-80c3-a716c0830691

Any advice would be helpful

1 Like

Hi @Derek_Morgan,
A few questions:

  1. Is it an image column or a file column?
  2. Is the image missing on every upload? Or just occasionally?
  3. Have you tried uploading images from other devices?
  4. Would you mind if I take a look in your app? To do so I’ll need to give AppSheet staff access in this page https://www.appsheet.com/Account/Account#_tab_acctConfig.

Hi Gil

To answer your questions:

  1. Is it an image column or a file column?
    Its an image column
  2. Is the image missing on every upload? Or just occasionally?
    Occasionally
  3. Have you tried uploading images from other devices?
    Yes problem only seems to be with Android, its work fine on IOS
  4. Would you mind if I take a look in your app? To do so I’ll need to give AppSheet staff access in this page https://www.appsheet.com/Account/Account#_tab_acctConfig .
    Sure I have done this

One more thing, when I get this problem a file gets saved in the folder “SiteInspection_Files_” rather than “SiteInspection_Images”. The file has the extension .jpg but it isnt a real image file. ’

Example here: https://drive.google.com/file/d/1Gnx6PaDAXdSMErPeh0znZvvfbt0cUkS8/view?usp=sharing

When I dont get this problem, the file gets saved to “SiteInspection_Images”

Thanks @Derek_Morgan,
I wasn’t able to find anything obviously wrong with the app. Could you please point me to a row with an image that failed to upload? If you can refer to me to an audit log entry that would be easiest, but rowID and time of upload would work too.
I’ll also need to know in which column was the image, since you have multiple image columns.

I have been having similar issues with field users intermittently. Specifically with the Android Samsung Tab A 10.1’. Any close up images are pixelated and blurred as well.
The image is captured and stored on the device, however the file name is not recorded in the table and does not show on any workflow reports.
I need test different camera apps with the device as it appears it could be a camera issue with the default Samsung camera.
When doing the same task with an iphone, the users / apps have no issues.

Hi @Gil

Sorry we were playing around with the data trying to fix it. An example is row 4 in the google sheet, Image Name “SiteInspection_Files_/ELM.Image 1.125533.jpg”. This is the same file as the hyperlink from my previous message. The problem has occurred previously in all Image columns, but the current example is column H = Image 1

I cant seem to do an audit log because we don’t have a corporate account.

@Craig_Clancy1, About the blurry image, does the copy that is saved on the device looks better? What is the “Image upload size” in your app setting (found in UX -> Option -> Forms)?
Do you get the same problem when selecting an image from the phone’s gallery?

@Derek_Morgan, Do you know the time of upload of this image? It will help me find the audit log for this row.

Hi Gil

The latest was June 5, 2:55 PM (GMT +2).

Another example was May 26, 5:03 PM (GMT +2), In this case the file was called “SiteInspection_Files_/6.Image 1.150349.jpg”.

In fact all the files in the drive folder “SiteInspection_Files_” are examples of when this happened with time stamps on when the file was uploaded to the drive. If you need access to the drive, let me know who to share it with.

Thanks @Derek_Morgan,
I managed to locate the audit logs for these images and I can see something went wrong with the upload resulting in an empty file.
I’m still trying to understand what went wrong.
Have you notice any interesting pattern when this is happening?
Is the user switching apps soon after taking the photo?
Is the internet connection spotty?

Also, would you mind trying turning off automatic updates (Behavior -> Offline/Sync) and letting me know if this is still happening? If you turn this setting off, users will have to press the sync button after every change they make.

@Gil

I have had similar issues with android users. Tablet is version 5.1.1 and model no SM_T365.

User reported issues capturing images, the image was captured and saved mid-form but returned the user to blank field input once the sync was finished.

We have had trouble with this in the past with similar model.

Thanks, Sarah

Hi Gil

I will try the Offline/Sync option and let you know. I don’t think this will help though because I remember when it happened on my phone there wasn’t a preview of the photo in the UI form after I took the photo and before the automatic sync kicked in. It was like the app never got the photo from the phone. Once the app started working properly, I could see the photo preview in the app UI before the sync even happened.

Regards
Derek