"Image could not be loaded" error that I cann...

ux
(Mike Adler) #1

“Image could not be loaded” error that I cannot seem to solve.

I have a table set up with a “thumbnail” column.

The thumbnails are .png files in my google drive.

When I try to use the images in a “deck” view, I only get error triangles displayed.

If I click on the triangles, a black panel opens with the error “the image could not be loaded”.

Interestingly, if I click the error (in the emulator), the image actually loads as a gdrive preview screen as another tab.

The table is set up with an Icon column and the hyperlinks test ok and look something like this: https://drive.google.com/file/d//view?usp=sharing

Can anyone help me figure out how to get the thumbnails to correctly display?

(Aleksi Alkio) #2

https://help.appsheet.com/ux/views/displaying-images-and-documents

(Aleksi Alkio) #3

Your URL link is not correct. You need to change it with the format you can find from the article.

(Mike Adler) #4

@Aleksi_Alkio!

Makes sense.

I tried help search but missed this support article.

Thanks for the direction!!

Much appreciated.

(Aleksi Alkio) #5

You’re welcome

#6

Just in case anyone else struggles with this, I also found that using a URL created another issue with my business domain.

Even the modified links

brought up a login screen before the image could be accessed (which means the error would continue).

Rather than URL’s, I switched to filepath and name and everything works as expected.

(Praveen Seshadri (AppSheet)) #7

Yes, when you use file names, our system handles the authorization tokens. When you use urls, they have to be public urls.

#8

Thanks @praveen.

Lesson learned :slight_smile: