Images not loading on new Card view

On the new Card view, are there any specifics on how images should be formatted or anything? Because unfortunately for me, and I think I saw at least one other with the problem, my images won’t load on it at all.
Card (backdrop):

But still works in Gallery:

It’s not just the editor or cache on my PC. The demo app seems to work just fine, but I can’t figure out why those pictures are working, but mine aren’t.

This in your wheelhouse at all @morgan?

Hey @Bahbus thanks for reaching out. I’m curious what your image URLs look like, and if somehow the view is not interpreting them properly. Is the issue that the images show up in the emulator but not the actual app?

As for the URLs, I am doing a simple relative filename.
image

The images work everywhere in every view, except Card. And the result is the same both in the emulator and the app. The only difference is the app doesn’t have the little broken placeholders like the emulator does.

Great thanks. I think I know the issue and will make a fix ASAP.

2 Likes

Awesomesauce. I knew you were the right person to tag for this! :slight_smile:

Hi @Bahbus I implemented a fix and it will be available when we deploy, likely tomorrow.

1 Like

Awesome, thanks! I noticed it was being weird in general. When I switch from Gallery to Card and it defaults to Large, it auto guess what should go where, and it does a really good job. However, it was showing every field as blank. If I tried to switch to a different type (backdrop), or if I tried to actually choose which fields to display from the dropdowns it would immediately switch to the screenshot as pictured (except with the various pieces attached to them for the different types). I don’t know if that is related to the fix you already dropped, but I’d would guess that is.

I’m having issues as well where the LARGE option isn’t displaying ANYTHING when selected, but the other three show at least text, and sometimes images.