In the expression editor, the "Test" button i...

expressions
(Green Gorilla) #1

In the expression editor, the “Test” button is not working. This started yesterday…

It verifies ok, and so on, but no “Test”.

Is this a bug?

(James W Rezin) #2

I have also noticed this in the Workflow and Actions part

(Michael) #3

Test is failing 80% of the time for me as well.

(Dinh Nguyen Nguyen) #4

@Green_Gorilla Hi, could you give us more information about the problem? What symptoms did you observer? Did you run into an error, and what was the error message? Did the test button not respond at all?

(Green Gorilla) #5

@Harry

Exactly as I said, it just doesn’t work. No error messages or anything. Just no response.

(Dinh Nguyen Nguyen) #6

@Green_Gorilla Could you help me run a small experiment: click on the test button of any expression builder in the editor. If nothing happens, click on it a few times. If still nothing happens, wait for about one or two minutes. Please let me know if the expression test result tabs all show up after one or two minutes of waiting. If they do, do they all show up at the same time, or do they show up one by one?

(Green Gorilla) #7

@Harry I am not on the computer I was using.

I will have to try that in the morning when I get to the office. It’s 11pm here…

(Green Gorilla) #8

Ok, it’s intermittent. I just did it now and it worked after a second delay, by which time I had clicked again, and 2 windows popped up. Then tried again, and nothing. Clicked several times, still waiting…2 minutes now…

(Dinh Nguyen Nguyen) #9

@Green_Gorilla After some debugging, we believe we have found the reason. Each time you click on the test button, the app editor will request the web browser to capture the user’s current location. This is necessary to compute expressions that require the user’s location to work, such as the HERE() expression. Only after the web browser captures the user’s current location will the expression test proceed.

It is possible that there has been a recent update in Chrome that causes the location capturing process to take a long time. We are still looking into this in order to devise a fix.

Adding @Sarah_Gould_AppSheet and @Adam_Stone_AppSheet

(Green Gorilla) #10

Cool, thank you. I wonder if there are settings in chrome as well that could cause it. Things seemed to be ok on another computer, but haven’t run a full test…

Cheers