Initial Value on Enum

Hi,

i’ve tried many times and also read various threads, but still do not able to make it works.

I’ve a very simple Enum with 2 text options button, no Appformula, no Valid IF; it’s just everything blank.
i’d like to set “NO” as initial value because i guess it will be mostly right. I’ve tried with “NO”,NO,=“NO”; nothing happen.

thanks

Use an initial value expression of FALSE.

This is my case; doesn’t let me set FALSE as initial value

Hola Marco,

En la propiedad INITIAL VALUE, escribe FALSE

Anotaci%C3%B3n%202019-10-02%20213223

Ah, right, it’s an Enum. My mistake!

An initial value of "NO" should work. Can you clarify what happens when you use an initial value expression of "NO"?

Nothing happens…there aren’t errors but just doesn’t work as expected; i would like to see the “NO” preselected.

Cattura1

Hi @Mark_11,

The settings appear to be correct.

Just in case, are you checking whether initial value is working with already saved, existing records? If so,request you to test the initial value setting by creating new record(s). The setting will not work with existing records. This is so because “initial value” is already considered as “blank” if there was no selection of either “Si” or “NO” by the user while saving the record and initial value was also missing earlier.

1 Like

oh, ok; i didn’t try with a new record in fact all my records are pre-uploaded because is a sort of database. There is no “add” function, only “update” to put into the rows only the missing information.

Do we have another method to solve the problem?

1 Like

Hi @Mark_11,

Thanks for the update. As per my understanding , for you existing records, if feasible, if there are just handful of records you may manually populate the expected responses for each button, either in the app or directly in the back end, because initial value will not help for existing records.

Also since there is going to be no new record, I am unable to think of a use case for use of initial value in your case for existing records.

1 Like

Leave the initial value expression as "NO". Set the Reset on edit expression to:

ISBLANK([_THIS])
1 Like

oh well, now seems ok; great! thanks to all

1 Like

Hi ,
I have just been trying to do this and found it worked when editing when I used
ISNOTBLANK([_THIS])

2 Likes