Invalidated old database data source credentials

FYI, we have been sending notifications and announcements for the past 3 months that any data sources connecting to database sources will need to update/refresh the database credentials. The cutoff date was April 14th.
I’m just posting this message to indicate that we have just invalidated the data sources that had not been updated. If you have an app that has now stopped working as a result of this, the steps to fix it are simple:

  1. Go to the Account -> data sources page
  2. Click on the database data source in question
  3. Provide the database username/password or any other credential inputs again. And Save.

I apologize for any disruption caused. As explained in the various communications around this, the requirement to make this change is driven by increased security protocols that we established as we were acquired by Google.

4 Likes

Hi Praveen,

This change was not communicated well. I only received a single email notification 2 weeks ago about this without any actionable instructions for how to make the updates, and frankly it was not the top priority on my plate. Now, when I try to follow the instructions above I get an error page when I click on the data sources for my account. I’ve contacted support@appsheet.com but in the meantime all my apps are offline. I’m not very happy with this situation.

James

4 Likes

I am at the same situation I guess. But I can not enter the database to enter credentials again. Whe I try to enter database to enter credentials, I only get a message Opps, something go wrong. How can you help me with that.

Following your instructions, but I encounter the error message, unable to recover the connectivities to all the data sources, i.e. all the app I deployed is currently NOT runnable, which is causing massive problems.

See the screenshot below.

seems it started working. Anything I should be doing now?

My ones do not work … hmmmm.

@praveen

We have been trying for an hour… no luck.

Yikes, looks like in some cases, the modify form is broken. We’ve figured it out, fixed it and the change is rolling out over the next half an hour.

2 Likes

I will re-try in another 30 - 60 mins - but do we need to take any extra steps, like log out / re log in, and clear cache etc?

No, the only change needed would be to modify the data source definition.

1 Like

Sure, will try in mins.

Still getting the same error message…

60 mins over, but still no change.
Fix is yet released?

Update: I’ve been able to get my setup fixed and my apps are working again.

1 Like

Fix reached out to me as well.
Now able to re-config the connection to DB, and apps are up and running again.

1 Like

We have been having customers update their credentials without a problem for the last few months.

The issue that happened today is that when we did the actual invalidation, I failed to ensure that an invalidated data source could always be modified — it could be in some cases but in other cases, it failed because the invalidated format of the database credentials was not being correctly recognized by our running code.

This is my bad (both as a leader of the team and also specifically as the person making this change). The change should not have been rolled out in this fashion and you should not have been seen downtime as a result of it. I apologize and we’ll try to do better going forward.

11 Likes

I never received one notice on this at all and only found out because we had someone not able to get into the app. Very frustrating!!!

One of my clients had the same issue this morning. The app is set up with an account they own, so I didn’t see whatever email was sent out. They may have gotten one and ignored it.

In any case, it seems like this is catching a lot of people off guard. I don’t remember seeing an email on it and I only learned about the issue when I saw @praveen’s post on how to fix.

@Peter is going to follow up with each of you. He has coordinated a whole email communication cascade over months, and it clearly was not effective in reaching you. So we have to get to the bottom of this before the next time we need to communicate things.

4 Likes