Is there a way to bulk sign tables?

I am trying to give my users a way to bulk sign my table. I want the user to be able to click on the select all button:
image

From there i want them to be able to choose an action button (that uses a certain signature to fill the table column [Signature]).

Maybe not in the direct sense that you’re describing here, but yes you can do this.

You’ll first need to have the signature on file - saved inside the app somewhere - then you can say to the system “copy that signature into all of the selected files.”

I have a sample app that’s surprisingly similar to what you’re wanting, it shows how to copy the signature from a parent record into all the child records.

https://www.appsheet.com/samples/How-to-use-Actions-to-copy-data-from-parent-records-to-all-related-child-records?appGuidString=ce60ae1e-0154-4e2f-af1d-c424969aa17b

1 Like

That’s exactly what i tried. Something is either wrong with my Signature table - or the way i and referencing it.

If you compare the sample app to what you tried, what is different?

its hard to tell - you have a lot more going on - in your app…

True - but if you look at the signature specific actions, that’s where you’ll likely find some difference.

Which table is your table where you captured original signatures? And which is used to get those?

“Signature_Capture” is the name of the table used to capture the signatures.

“Signature_Copy” is the name of the table that I will copy the parent-signatures into.


The key part to look at is the following actions:

  • Set | LOOKUP (Parent Signature) - on the child table
    • This action is the element that actually copies the signature to the selected record
  • Ref Set | Update child signatures - on the parent table
    • This action groups all the related child records together, then executes the action above on them.

The way the sample app works is as follows:

  1. You create a new parent record (on the “Signature_Capture” table);
  2. You add child records to the parent (these populate on the “Signature_Copy” table)
  3. After you add child records to the parent, you can sign it; after you sign it, you can save the record
  4. This in turn triggers the Save event (from the form view) that has a composite action selected to execute, that then copies the signature from the parent into all the related child records.

The way this works is two fold:

  1. You have an action on the child table to do a lookup of the parent, find the signature and copy it into the signature field of the child table (this is the “Set | LOOKUP (Parent Signature)” action from above);
  2. You have a composite action to execute the above action on all the related child records (this is the “Ref Set | Update child signatures” action from above).
1 Like

ok - i thought so- let me double check my tables… Thanks

1 Like

So now my button to select multiple items - went away?

Also - btw. I cannot get your app to do anything - when i click on a button. I have tried several times re opening it. I am not sure why…

So i am still confused and not getting this to work. I do not understand why this doesnt work:

I made a table - setting up one user signature. So the user made the signature - and it has a key:

Then in my other Table (Payables) i have a link:

Then i created a button to link - “change” the data for column - “Tabatha Signature” —>> signature from the Signature Table:

image

Any thoughts on why this isn’t doing anything? I don’t get any errors. And i can click on this button - but the data does NOT fill the table.

After seeing your table setup, there’s a better way - use a de-reference to pull the signature from the ref column.


In the app formula for the actual signature field, use the following formula:

[Tabatha Linked Signature].[Signature]

That tells the system: “Look at the [Tabatha Linked Signature] column, we have selected a reference; from that reference we want the Signature value”


Using this setup will cause the signature to immediately populate when the signature reference is selected.

In regards to why setting this up as an action doesn’t work… that is strange, and I’m not sure why.

Ok. I did that - but now my button says - i cannot modify that column - “Tabatha Signature”? Do i just delete the button all together?

check that the column is editable, the switch my be set to off (greyed out)

did that work?

No - It was already editable? I had to delete the action button - as it wont let me change it - i guess because the formula?

Oh, yeah - you can only have one or the other.

But with the de-reference in the app formula - did that work?

You’ll have to go into the form and actually select the reference in order for the signature to be imported.

Yes. It does work - however - they still cannot BULK sign. What it currently does:

The user chooses from the drop down - her name - [Tabatha Linked Signature] - then that AUTO populates the actual column [Tabatha Signature].

This is WAY easier than having to write out each signature - but i still cannot MASS/BULK sign?