Is there a way to tell an Appsheet Column NOT to delete a Spreadsheet formula when a row is added?

Hello,

I’m trying to fix a something … and an easy way to do it is to have a formula in the Google Spreadsheet I use for Data.
But, everytime I add a new row to the Table, whatever formula I had in the spreadsheet is erased (understandable).

I’m wondering if there is an option to tell the Appsheet column NOT to delete the Spreadsheet Formula? and take the value that the Spreadsheet computes?

Thank you,
Sorin

hi yes, add your formula to every existing row,(maybe even delete all blank rows), and regenerate immediately. appsheet is looking for the formula to exist in all rows or it doesnt work right. once this is done it will add the formula to each new row.

1 Like

Yes.
Secodns after I wrote the post I tried turning the column to Not Editable and it was working just like that.
But doing your method afterword (just to check the difference) Appsheet set the column to Read Only by itself so that feels and informed me of the presence of the Formula in the Spreadsheet, so that feels much safer :smiley:

Thank you

Hi, I am experiencing the same issue and tried both solutions suggested (delete all rows and changed the columns to not “Editable”. Every time I enter a new row the formulas are deleted.

After you click the “Regenerate” button check for warnings on the Info > Error tab.
You will probably see warning about the formulas in the column not being identical.
Appsheet only recognizes the formula and applies it to every row if every cell in the column has the same formula.

See https://help.appsheet.com/en/articles/3326638-mismatched-spreadsheet-formulas

After Regenerating, there are no error warnings that flag. I’ve also deleted all blank rows and all formulas in the same column match. The row formulas only change to correspond to the new row’s cell source: =IFERROR(VLOOKUP(H2,‘Navigator Staff’!$B$1:$D$5,2,FALSE),"") - H2, H3, H4 etc.

I’ve also now noticed that when I make a change in my spreadsheet the app isn’t updating.

Please disregard the change to spreadsheet not updating to app. I didn’t add the key.

When I enter the data in the spreadsheet the formula works appropriately and displays appropriately in the app. It is only when I enter the data through the app that the formula is deleted in the spreadsheet.

Also, when I enter the data in the spreadsheet and then go into the app, the formula works as well.

It seems as though it is only when I first create a new row, appsheet is deleting the formula. It is not entering the new row at the bottom but the next open row which contains the formula. Thank you!

Sigh after hours of this I finally figured it out. I needed to create a header, input at least one row of data, delete all blank rows, make sure all cell formulas were the same, and then immediately regenerate the data. Thank you though!

When you go to Data > Columns tab and look at the table’s properties, what does the “Spreadsheet formula” property of that field contain?

Our posts crossed. Glad you figure it out.
If you check the “Spreadsheet formula” property, it should now be correct.