Is this a bug with the card feature?

I am using the card view here and i noticed that sometimes the percent doesnt stop. See below:

I made this a Type- Percent:

I used this formula:

Have you specified that the column not to do that in the column’s settings?

is this where?

Decimal digits. Try just changing it to 1. Save, sync, see what it looks like, then try changing it back to 0, save, sync. I’m curious if the behavior changes and then fixes itself, or changes back to this.

I changed decimal digits to “1” then back to “0”.

Still doing the same.