IsPartOf button not appearing in Form

Hello,

I have a bit of an odd situation in trying to set up some References between some table, with the IsPartOf Tab ON.
What I really love about it is that when you fill a Form with it ON in the Parent Table, at the end it asks if you want to Add some Child Rows directly from the that Form. And that is AMAZING.

But one such relationship works but another one doesn’t and I have no idea why. I’ll explain here the set up for both:

So again, Task Management App - Projects have many Objects, Objects have many Tasks, Tasks have many times.

  1. Form the Objects Table, I made a Reference to the Projects Table and marked it IsPartOf.
    And when I fill a form in Projects, at the end of it it asks if I want to add an Object:


(and I can keep adding Objects to that project before hitting the Save button and saving everything - Perfect)

  1. I tried doing the same between Tasks and Times (exactly the same). Also, here in the Task_Form I selected to automatically reopen. So when I start making a Task I would love to be able to either keep making Tasks or Make a task and start adding Times to it (for when I have been working on something that has not yet been created as a Task, I want to make it fast and complete the Times spent on it on the spot, and then save both the Task and the Time).

However, the button does’t show up … the text from the Description of the Referenced Times List in the Tasks Table shows up though … but not the button.

Any ideas what I’m missing here?
I can’t think of any difference between the two situations.

Thank you?

Maybe stupied question… have you checked that the Is A Part Of option is set as ON in your Ref column? Another reason… you can only have one Is a Part Of Ref field at the same with your table.

Yes, it is turned ON and what is strange is that the connection works, since the messege of adding a new Time appears IN the Tasks Form … it’s just the button that doesn’t. appear.

So the Objects table IsPartOf the Projects table, and the Times table IsPartOf the Tasks table. So no table is tryin to be PartOf two tables at once.
Also I tried now turning off the IsPartOf from Objects and left the Times on, but it’s the same.

However, there are references between these tables, without the IsPartOf turned on.
The whole app works great, the IsPartOf from the from the Objects to Projects works great…I don’t know what is special about this one …

Hy,

Any ideas why it might happen? You think it might be just my app?
Should I write to support?

Thank you,
Sorin

Yes, please send this with details to support@appsheet.com

What was the solution to this problem?