Issue with setting column values within a bot

I put this under workflows for now but I am specifically talking about a bot.

I am having an issue using an action within a bot to set column values. Here is an action that a scheduled bot is running. The row filter for the bot is TRUE

When using the “RUN” function on the bot I would expect that all the rows for column 10 will now be 1 (as seen in the screenshot ) however, 0 rows are updated after running the bot. Is this somehow intended functionality?

I have tried multiple troubleshooting steps here. I verified that the table does indeed have write privileges and I even attempted bypassing the security feature just incase. Nothing I do seems to properly set the column values as I want. Anyone have insight on this?

Did you check the monitoring App ?
Does it show that the Bot was run ?
Is the Bot enabled ?

2 Likes

Is “ForEachRowInTable” turned on?

1 Like

Yes, I used the “run” button and confirmed its running.

Try making the Action visible in the record so that you can manually click the button and confirm that it writes the data. Also consider going into Monitor on the Bot to look at the logs

Simon@1minManager.com

2 Likes

Appreciate the suggestion. I tried this, after clicking the action button it does indeed fire off correctly as intended. just not sure why it wont work with the bot. It seems to be the fact its a scheduled bot and not a data triggered one (it needs to be a scheduled bot).

Odd thing is though, there is an email task before this one in the step/process. This fires off as intended. For troubleshooting purposes I have temporarily limited it to the one step stated in the initial post/issue.

Have you checked out the Monitor button on the Bot to see the logs?

Only other thing I think it migh be is that your table size is either large or you have lots of equations. Try settting a row filter of something like [_RowNumber]=100

1 Like

Check the audit log as well. Each data change action should be registered there.

1 Like