KML no longer showing

Hi there.
I have been using a KML on our map views for quite some time.
I am finally getting to the pointy end where I may get my customer to commit to paying for licenses and rolling this out but I need to demo it again and now the KML file has gone.I use the KML file as we are working on a road construction job and it shows the new alignment of the road which is important since Google Maps is still showing mostly the old alignment. The asset locaitons make more sense over the KML.
I use the same KML in a number of apps and it is not showing in any of them.
I have tested app sheets connection to my google drive and that is fine.
I have tried creating the permalink again and that doesn’t help.
I have opened the KML in Google Earth and that works fine.
The permalink is http://drive.google.com/uc?id=1j1kOST-mCO_C5AVg0qsShHiQjplcyV1x

Maybe this?

I don’t think so since I have the security options turned off. I did this when this change first happened so that images and PDF’s would still work.
image

1 Like

I create a permalink from the share link on Google Drive.
The result looks like this:
http://drive.google.com/uc?id=1j1kOST-mCO_C5AVg0qsShHiQjplcyV1x

That is added to the KML address for the Lat/Long field.

If the security change is the reason this isn’t working, even with security settings turned off, how do I fix this so it works?

Happy to make the changes but I don’t know what changes are required at the moment.

1 Like

Unfortunately, I have zero experience with KML files. The best I can do at this point is encourage you to engage support@appsheet.com.

Hi @Mordan74 to me this KML Link is working:

This is how I set up the Address column:

Please try using https instead of http in your link. This sometimes helped me.

2 Likes

Thanks for that. I will give it a go when I get back to work on Monday and let you know how I go

OK, because I am very impatient I decided to try it before I got back to work.
I loaded it up and didn’t have to change anything because it was working again, all by itself.
I’m probably more concerned now as there was obviously nothing wrong at my end :face_with_raised_eyebrow:

That’s interesting. I also noticed, that this feature is not always very stable.
Adding @Peter