Linkform not working

Hi,

I’ve been dwelling with my linkform formula not working for sometimes and after reading some of the post I still not understand why its not working.

Goal: I want to Prefill the CID from table 1 to table 2
Table 1: the source of CID
table 2: prefill CID from table 1

How I imagine the workflow is
User will see the dashboard view for table 1 and when they click through they can copy the CID into table 2

I’m setting a behaviour where app: go to another view within this app

formula I tried
LINKTOFORM(“bast1 Form”, “cid”, [cid])
LINKTOFORM(“bast1 Form”, “cid”, [_THISROW].[cid])

Please help as I dont get the idea why is this not working

Thanks in Advance!

In what way isn’t it working? Does the action button not display? Does it display but do nothing? Does it take you to the form but not fill in the data? How is it not working?

1 Like

Hi Steve,

Sorry for not being clear. When I press the action button it leads to blank page

Please refer to the images

1 Like

That suggests the form you reference with LINKTOFORM() doesn’t actually exist. Is the a form named bast1 Form in the UX >> Views tab of the app editor?

Yes, in the ux it shows under reff views

This is the formula that i use

This is the table i mentioned

Your LINKTOFORM() expression targets bast1_form, but the correct form name is bast 1_Form. The upper/lowercase F doesn’t matter, but the space between bast and 1_Form must be there. Try that.

2 Likes

Thanks alot in pointing all the steps Steve!

1 Like