Linking specific FORM to table row select

Hi everyone - new here… first post.

When I select a row in the table below on the left, I want it to open a specific form to edit just the relevant info. The form includes columns that appear based on values (e.g. if an invoice is switched from “payable” to “paid”, the payment options appear, etc.)

It was working perfectly yesterday.

And I cannot figure out for the life of me how to get those columns to show in the form.

I’ve tried:
Table behavior on row-select “auto” - and it takes me to the detail view with all fields, and requires an extra click to see the form
Table behavior on row-select “edit” - it opens a form with half the columns I need, even though it seems to be pointing the custom form I created with custom column order
Table behavior on row-select “run an action” - If I use “App: open a form to use this row” I get the same problem as above
Table behavior on row-select “run an action” - If I use “App: go to another view within this app” it takes me to the form I point to, but doesn’t take me to the related record…

I was working perfectly (I was using “App: open a form to use this row” - until it suddenly didn’t anymore, and I’m not sure what I did different… I tinkered with the underlying data, that I am using as dummy data to test the features, but that’s all I can think of.

Also, agin… new here… I could’nt think of how to this more concise. See please, if you don’t mind, let me know if this message conforms to the community standards…

Thanks in advance

Below the emulator, double check that you are indeed inside the View that you think you are in:

If you have columns set in the Column Order setting for the view, but they aren’t showing, chances are that those columns aren’t editable, or have a Valid_If expression that is returning a blank List, or they have an App Formula that is outputting nothing. Appsheet likes to auto-hide columns when there’s nothing you can do with them.

LINKTOROW() is what you want to use if you go that particular route.

1 Like

@Marc_Dillon Thanks Man!

I tried removing all of these options (all are set to text, data require, no formulas, are not virtual columns, searchable, editable, etc.), but to no avail… When I open the form on its own (not by linking from a table row), it still only displays a selection of columns. It’s very confusing as it was working perfectly earlier…

Will try the LinkToRow… and check the view you are mentioning…

And pardon my ignorance… LINKTOROW() is a formula to use within a column?
or is it an action? I can’t seem to figure out how to use it…

In a “go to another view” Action, is what I was referring to.

1 Like

Got it. That’s really helpful… Takes the guessing game out of what Form the table is linking to.

Looks like it should work…

However I’m still struggling to get it to open the related row, rather than a new row…

Here’s my formula:
LINKTOROW(“REF_NOTA”, “NUEVOS_NEW_CustomForm”)
the form name is working for sure…
the column name is where I think I’m struggling… It is the key in this table.
I’m guessing this is pretty basic stuff… sorry for my ignorance…

You don’t send the name of the key column, you need to send the key value of the record you want to edit.

If you’re using this Action on a row-select the easiest way to do that is to use:

LINKTOROW( [_THISROW] , ... )
2 Likes

Thank you @Marc_Dillon !!! You’re the best
Problem solved!
Very much appreciate it.

2 Likes