Links to Images in PDF WorkFlow

Hello Everyone,

Im creating a workflow template and am in need of displaying the links to images.

Ive set the image columns in the Workflow template format as text.

This is whats happening when clicking on the link.

In my template Im just putting in the Column name Packing Slip: <<[Delivery Slip Image]>>

Thing is, if its in the email body, the link does work?
Any suggestions?

Seems like the link is not wrapping itself around the cell. It is just a partial link. Any ideas on how to fix this?

Partial link in PDF

Full link in Email body

Hi @Jonathan_S try using Hyperlink to an Image as mentioned at the bottom of this page:


Or try this: Packing Slip: <<CONCATENATE([Delivery Slip Image])>>.
Or try to set the font size to 1px.

1 Like

Ive tried the 1px,
Been trying everything. Ill try the Concatenate.

Edit: Concatenate breaks the link.

Im using the fuction of setting the format to text exactly for what it has been designed to do. Makes a link to the app sheet server. Anything else breaks this link.

The main problem is the text is not wrapping and at 1pt the link is unclickable, at 2pt it overflows the page.

So I think it’s time to send an E-Mail to support@appsheet.com :slight_smile:

2 Likes

Working with them all day. Was hoping someone here would have input :slight_smile:

I’ve made specific virtual columns to hold links to my images, for use in PDFs.

CONCATENATE(β€œhttps://www.appsheet.com/template/gettablefileurl?appName=”, ENCODEURL(β€œapp name”), β€œ&tableName=”, ENCODEURL(β€œtable name”), β€œ&fileName=”, ENCODEURL([Image]))

Then use the HYPERLINK expression in the template.

<<HYPERLINK( [imgLink] , ”IMG” )>>

Of course now you’ll have to disable a security option for this to work, as per the following post:

3 Likes

@Aleksi Thank you for helping me for the past 4-5 hours to try to get this figured out.
@Marc_Dillon Thank you as well. Your Formula should be put into official documentation.

In the end Still not sure what it was, Will keep tinkering around and trying things. @Aleksi

I do believe the wrapping issue should be resolved by the team. @praveen

1 Like

Why is it that this formula Works for some images but not others?

The first one I did works, shows up bright blue in pdf,

I did 2 others from a differant table and they show up purple-ish, as in they have already been clicked on or somthing and there is no link associated with them?

Did the same thing, they all have there own virtual column, when I test the formula out in appsheet it works perfect, I can copy and past the results from the editor into my browser and I get beautiful images, but in the template, 2 of the 3 links dont work.

Any insight? You seem to have a ton of experience with this.

Edit So Trying it in a Email Template Makes it look like a Hyperlink like the working one, but doesant function.

The images are in a child Table. But Im pulling allot of other stuff from this child table with no issues. So Im not to sure.

This is my functioning one.

Non functioning. Ive tried this without checking if the Column where the Hyperlink is created from is blank etc.

In my Email Body Template Top one works, Bottom link does not work.
Email Template

In My PDF Template Image A & B dont work, Delivery Slip one does.

It is. https://help.appsheet.com/en/articles/961605-displaying-images-and-documents

Uh, not really much info to go on here. You can check the raw HTML output of the workflow template with the workflow Test button, see if that has any clues as to what is actually being output. Are these other images in a different spot in the template?

2 Likes

See above. Kind of different spot? Same template though.

Here @Marc_Dillon

Ive done this and the output is good. I can copy and paste this in browser and get beautiful images. Never mind, this was with the virtual column Test. Let me try this.

Edit Ive highlighted the Difference in Bold

class=β€œc1”><td class=β€œc23” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc35”><span class=β€œc17”><span class=β€œc17”><span class=β€œc9 c22”><a href="">Click Here - Image A

<td class=β€œc23” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc35”><span class=β€œc17”><span class=β€œc17”><span class=β€œc9 c22”><a href="">Click Here - Image B<td class=β€œc48” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc16”><span class=β€œc7”>Total:<td class=β€œc28” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc16”><span class=β€œc9”>32,000<tr class=β€œc45”><td class=β€œc50” colspan=β€œ2” rowspan=β€œ1”><p class=β€œc8”><span class=β€œc0”><p class=β€œc11”><span class=β€œc26”><span class=β€œc9”><td class=β€œc48” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc16 c32”><span class=β€œc5”><td class=β€œc28” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc16 c32”><span class=β€œc9”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><p class=β€œc8”><span class=β€œc0”><a id=β€œt.8b4b50b2f0b4052d29324”><a id=β€œt.16”><table class=β€œc12”><tr class=β€œc1”><td class=β€œc34” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc11”><span class=β€œc7”>Received By: <span class=β€œc17”>Henry<td class=β€œc47” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc8”><span class=β€œc9”><td class=β€œc25” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc11”><span class=β€œc5”>Signature:<tr class=β€œc1”><td class=β€œc30” colspan=β€œ1” rowspan=β€œ1”><p class=β€œc11”><span class=β€œc17 c22 c42”><a href=β€œhttps://www.appsheet.com/template/gettablefileurl?appName=Recing-1160&tableName=Recieving%20Forms&fileName=Recieving%20Forms_Images%2F8e.Delivery%20Sli%20Imge.14.m._72”>Click Here for Delivery Slip

Seems likes its not making a link???
Its coming from a Child Table but this really should not make a difference, I’m able to get everything else from this child table, Evan the images direct. + grandchild table.

1 Like

Just do double-check:

OK, been trying out allot of random stuff.

I Instead of putting the hyperlink in, i change 1 of the 2 to the acual image where the hyperlink is being build from.

The one in greed works, while the one in red just makes a broken link. Does-ant function. Im completely lost here

@Aleksi Im not able to message you. Conversations Closed. but I tested with new image and record and old image and record.
Also tried contacting support, filled everything in 3 times and it just says url broken,

Guys,

You wont believe this facepalm. :crazy_face:
I just figured it out.
It was not in one of my slices. Usually this doesn’t matter but I was using a slice to rearrange a grandchild table.

Hopfully this will help save some grief from someone else,

Stay safe everyone,

Thanks!!! Awesome support.

3 Likes

Slices are killing me too on a regular basis :rofl:

3 Likes