List of Refs shows entire table instead

Hi AppSheet community,
I am fairly new to AppSheet, so I’m not sure if I I’am not getting it (yet) or if it is an actual issue. Hopefully someone with more experience can give me some pointers.

Summary:
In a ‘Detail’ view, a list of refs column shows me the entire referenced table (6 rows) instead of the actual filtered list of values (2 rows) as defined in the column.

My tables:

  • Table ‘Words’ is my referenced table. It contains 6 rows
  • Table ‘Expressions’ has a column [Related Words] which is a list of refs to table ‘Words’

Lets look at row ‘newid0005’ in table ‘Expressions’

  • Looking at the ‘Data’ view from the table itself, column [Related Words] shows a list of 2 references. This is expected
  • Looking at the ‘Detail’ view, the [Related Word] column show a summary of “(2)” in its title, as expected
  • But in the same ‘Detail’ view, the itemization of column [Related Words] shows 6 rows. That is the entire table ‘Words’. I was expecting to see 2 rows only.

All rows of table ‘Expressions’ have the same behavior with an 6-row itemization in the ‘Detail’ view regardless of the content of the column.

Note that the next column [Related WordsInExpression], another list of refs, show a proper itemization in the ‘Detail’ view, consistent with the content of the column.

As per the data representation of the table, my expression to build the list of refs gives me the expected result. It’s the ‘Detail’ view that does not seem to honor this result… I am confused.

Question:
Would anybody know why I am seeing a list of 6 rows in the ‘Detail’ view when the same column only contains a list of 2 references?

Thanks for you insights.

1 Like

Hmm. I’ve seen a few other complaints similar to this recently. There may be a bug here.

Please post a screenshot of the column configuration screen for the Related Words column that includes at least the top section, the Type Details section. and the Auto Compute section.

@Steve , thanks for the reply.

I have been playing a lot with it since yesterday trying to figure it out or work around it. The behavior is different today, and I am not sure if it’s because of my own changes. It is however still unexpected.

Today, I am no longer seeing what I described originally (6 rows instead of 2 in the itemized view of references)…

… instead, I am now seeing an empty list of rows, where I an (still) expecting 2. So still inconsistent as far as I understand.

Configuration of column [Related Words] in table 'Expressions’
Below is the screenshot you asked for (let me know if I misunderstood you, happy to give you what you need).
Note that there is no Auto Compute section.

Inconsistent Itemization of referenced rows"
Below is what I am seeing today, with an empty itemization of the [Related Words] column that should actually contain 2 rows".
The other columns containing a list of references are consistent, like I mentioned in my original post.

Thanks for looking into it :slight_smile:

1 Like

Hmm… (again)

The count n the header (the 2 in Related Words (2)) is generated independently from the list of rows displayed in the inline view. It’s possible that the expression that gathers the rows to display (the column’s App formula expression, in this case) could produce a list that includes duplicate results and/or invalid row references, meaning the count of list items could include items that aren’t displayable: duplicates and invalid row references are not displayed. Is it possible your SELECT() expression produces duplicate rows, and/or invalid row references?

@Steve , looking closely again, everything looks as expected, except for the itemized view. I hope I’m not missing the obvious.

Column [Related Words] of table ‘Expressions’ seems to be referencing existing rows of table ‘Words’, without duplication

See the few screenshots below…

Expressions’ table: Column [Related Words] lists 2 references (no duplicate): 15b0dfd4 & c2eb1fff

Words’ table: Contains both keys 15b0dfd4 & c2eb1fff (among others) as expected.

Both tables look good and consistent actually. I’m still scratching my head…

2 Likes

The only thing I can think, then, is that it’s a bug. Please contact support@appsheet.com for help with this, the report back here with the findings, if you would. :slight_smile:

1 Like

Thanks @Steve . I will contact support then.

Last question before doing so… Could the missing rows be caused by the way the ‘Detail’ view is set?

One thing is that I could not understand is how to configure the sub-view itemizing the referenced rows:

  • Which column to show or hide
  • In which order.

I am assuming the UI is calling a specific view to do so, but I don’t see/understand the way for me to specify which one. Such a view must be defined somewhere, right?

I am wondering if I may have set up a weird view somewhere with obscure rules filtering out rows, that the UI may be picking up without me realizing it. Not likely, but possible.

Below an example of what I am talking about:

Do you have any insights on how to control the way the referenced rows are displayed?

Thanks for your time Steve, I much appreciate it!

1 Like

The app will configure the inline table using a table view for the table (or slice) named by Referenced table name in the column’s configuration:

in the Ref position:

The system often creates the view configuration automatically, giving it a name with the _Inline suffix:

2 Likes

:+1: Thanks @Steve !
I had no idea. I will look into this.

1 Like

@Steve , I’m finally back to it.
I see indeed a table Ref View with an _Inline suffix associated with the data table in question. It is an auto-generated system view as you suggested.

Unfortunately, this is not the one used to display the itemized referenced rows in my Detail view. Instead, it is using another table Ref View that I created myself.

  • System view [Vocabulary_Inline] is the one I’d like to show for the itemization
  • My own view [Vocabulary] is the one actually showing

I tried to delete the _Inline view and it came back (as expected), but my Detail view keeps using the wrong Table view to display the itemized referenced rows. I don’t quite see how I could to force it…

1 Like

Ah, yeah. If you create your own view in the ref position, it will be used rather than the system-generated one. To wok around that, you’ll need to create a slice for one of the views.

  1. Create a slice on the same table.

  2. Reconfigure the column to use this new slice as the source table.

  3. Configure the inline view for the new slice as desired.

See also:

2 Likes

@Steve , thanks using a slice is a great tip. I didn’t think of it as a workaround but it sounds logical.
:+1:

[UPDATE] It worked like a charm! I definitely need to give slices more thoughts.

2 Likes