Location inconsistencies

I have created several apps that are linked by a launcher app. I am seeing inconsistency in how the lat/long fields are working for the locations. I am using the same device that has previously worked perfectly for locations, but unfortunately i am seeing it working sometimes then other times when i go into the apps it is not picking up my location. All location settings are turned on. Can anyone assist?

Cheers

Neil

Is the app simply not pulling your location at all, or is it reporting an incorrect location? If it is bringing in inaccurate location data, how offset from your actual location is it?

My first thought is that you may just be getting an inaccurate reading from your device GPS due to being inside a building. A solution there would be to manually adjust the latlong after your device has taken its best shot at placing you.

Most (maybe all) GPS satellites are not in geostationary orbits, so you may experience variance in accuracy due to their angle relative to your position changing throughout the day.

Hi it’s not pulling in location at all as per screenshot.

Previously this has worked fine from the location I am in, and i have full data and WiFi on phone.

I have the here() formula as my initial value and up until this week has worked totally fine from the same location.

@Neilemmo
Time to time the GPS accelerometer of the mobile devices might need a re-calibration. Have you tried with after re-calibrating your GPS accelerometer of the device? Does it still response in the same manner?

1 Like

Hi I am using a latest iPhone device, do you have any guidelines on how to recalibrate ?

Cheers

Could it have anything to do with the fact I’m using the launcher type app to load in the apps ? Just I have one if them downloaded and when I go into the app directly the lat long seems to work, but when I go through launcher this is when location isn’t working ?

@Neilemmo
Please check this out:

1 Like

Hi followed guidelines and reset phone and no change … all of the settings for calibration were already in place . I’m using iPhone XR with latest iOS installed . ???

Hi I am still having issues with the location. It doesn’t appear to be working on any iPhone devices properly I have now tried on 4 iPhones. But is working on Android. Can you help ?

@Neilemmo
I believe it could be a good idea to report this directly to support@appsheet.com

1 Like