Login access denied by Google

I tried logging in to my APPSheet account today and Google is telling me I that Access is denied. The full error message is as follows:
“Access denied by a security policy established by the Google Apps administrator of your organization. Please contact your administrator for further assistance.”

I checked my admin setting and APPSheet “Data Access” is granted to everyone in my org.

Any suggestions??

1 Like

I’ve run into the same thing @DougCrann.
I’ve not logged into this particular app sheet app (I’ve created different apps for different co’s. so I use a company email/app) in a LONG time…

Where did you find the AppSheet ‘Data Access’?
In ‘Security’ in Google’s Admin panel, I found ‘API Permissions’ and I granted ‘trust’ to AppSheet specifically, but that didn’t seem to help either.(even tho I’ve not had to do that elsewhere…)

Any thoughts anyone?

Thx for the response @Tim_Martin: Update on my issue… I tried logging in using my other computer this morning (mac book air) and have not encountered the same error. So I can now access my APP sheet account just not on my MacBook Pro (not issues logging into the mobile APP either). Spent 45 minutes online yesterday with Google tech support (who are really quite helpful and incredibly accessible and responsive I might add) and they could not find any errors in access settings or permissions etc. Still stumped… I even did a hard drive erase and reinstalled my O/S on the Mac Book Pro and the issue still persists…

I too am having the same issue across my company. It started yesterday.

This message suggests to me that your Google account is likely your work account, not your personal account, and that your employer has changed the policies for your work account in a way that prevents AppSheet from interacting with your work account. You should probably talk to you employer’s IT staff.

Count me in here as well. Just noticed it happening today with a couple staff. Seems to be device and not account related. I can sign in on my iMac, Android phone, but not my iPad.

Any resolution on this?

I’m having the same issue, and I am the IT staff! I haven’t changed anything.

1 Like

I’d think the appropriate escalation path would be Google support first (as @DougCrann tried), then AppSheet support.

The nature of the message suggests to me something to do with Google, but I have no experience at all with policy or app permissions, so it could just as easily be an AppSheet thing for all I know.

1 Like

UPDATE: I signed out of my appsheet account on my iMac. When I attempted to sign back in, I got the “Access denied…” message.

If the AppSheet site itself is denying you, go straight to AppSheet support: email support@appsheet.com.

Something is amiss with the third party authentication between AppSheet and (it seems like) just Google specifically. Given @DougCrann 's 45 minutes with Google support with no resolution, it is probably some internal/back end matter. I am going to contact AppSheet support, though.

1 Like

We have been trying to reproduce this problem with our own Google Domain, but to no avail. Quite frustrating.

This is definitely not a platform-wide problem — we have thousands of customers with Google domains and only a few have reported this problem in the last few days. So it is probably a behavioral change or new admin feature Google has introduced that is biting us in these instances.

If one of you is a google admin for your own domain and is willing to work with us on this, please send me an email (praveen@appsheet.com). We’ll probably need to do a live screenshare session, open the google admin console on your side, and look at each of the options in the security pane. I’ve learnt that it takes 5-10 minutes for security changes to the domain to percolate out to all the Google servers. So it might be a slow trial-and-error process.

3 Likes

This would be one thing to look at if you are a Google admin: https://admin.google.com/AdminHome?fral=1#MarketplaceSettings:flyout=basic

Also, this should show an audit history of successful and failed attempts at app authentication.

https://admin.google.com/AdminHome#Reports:subtab=token-audit

I just spent an hour in an online call with @DougCrann (thanks Doug!). But alas, we could not get to the bottom of this.

In Doug’s case, three of his four machines (an Android phone, an iOS Tablet, and a macbook) work fine. But one Macbook Pro alone fails the google security policy. We checked the audit log in the google admin console, and it shows no failures. So this is quite wierd.

Doug also created a dummy account for me in his domain. When I try signing in from my machine with that dummy account, it works fine.

I hope @Max will be able to help us troubleshoot this on Monday, since everyone in his domain seems to be hitting this failure.

2 Likes

I know at least a couple of you are talking with Google cloud support and are being told that the error message is not generated by Google. This is not true, and please push back on them. Here for example is a stackoverflow thread where other folks ran into the same issue with the same error message. https://stackoverflow.com/questions/25508740/policy-enforced-error-when-exchange-oauth2-token-for-google-plus

I suspect the root cause is that Google is deprecating the Google+ APIs. We used to request user email via an authorization scope tied to the Google+ API. That has since changed to using a different scope. We are now only requesting the new scopes. However, when old authentication tokens are being renewed, I notice from audit logs that Google seems to still be requesting the older scopes as well (things like profile.email). My suspicion is that Google is starting to roll out some change, it has rolled it out to just a few of their authentication servers to test for issues, and this is one of the effects of that.

If you are engaged with Google’s product support, please pass along my theory. We have no way to verify it on our side. We cannot reproduce the problem ourselves on our logins, but we know what our login code does. When it gets an error from Google, it shows the error.

5 Likes

I’m a G Suite reseller and AppSheet and I’m experiencing the same problem with only one user in my domain. The failure happens regardless of the machine where the machine is accessing.

I am willing to solve the problem through remote access.

Anyone who has the time to investigate this today, please LMK — praveen@appsheet.com. I’m on the US west coast, pacific time.

Good morning, Praveen.

I’ve been talking to David about the authentication problem. He informed me that according to the logs he does not use Google+ as the scope of authorization.

Google has given me these steps as a work around. It is still unclear why the issue is occurring but this at least is a temporary fix.

  1. Log into a G Suite account that cannot get access to AppSheet ( logout of all other google account ).
  2. Go to https://myaccount.google.com/security .
  3. Scroll to “Third-party apps with account access”.
  4. Click “Manage third-party access”.
  5. Select AppSheet and remove access from the list.
  6. Wait 24 hours.
  7. Sign into the Google Drive with the same account in incognito mode ( no extensions or cookies visible ).
  8. Select a Google document that is being used by AppSheet.
  9. Right click and “Open with” -> AppSheet.
  10. This should bring you to the authorization screen for which resources AppSheet is requesting access.
  11. Allow the requested permissions by AppSheet and hopefully this will resolve your issue.
2 Likes