Making an app Public in your portfolio

If you want to make an App public in your portfolio.
1 Open the App
2 > Manage
3> Teamwork
4> Make this app a public sample
5> Click on Change visibility
6> Click on the not deployed (in red top left corner of editor)
7> Change to deployed
8> Go to My Account
9> Collab
10> View my public Apps
Your deployed public app should be in there. Share the link to this page if you want someone to check out your public profile apps.

8 Likes

Great tip!

2 Likes

Thanks @Lynn! (Cc: @Peter) I think these steps are very helpful.

I’m still not completely sure, however, why I’ve gotten the following warning:

Is it because of the order in which I took the steps? In my case, I deployed first and then made the app a public sample. Is that why I got the e-mail? Does that mean that, since I made the app public as a prototype, I can ignore this warning? If so, perhaps AppSheet should not be sending out warnings if in this kind of case.

By the way, @Peter, I made a sample app to demonstrate a problem I found with the format rules:

As I want to get my app up and running soon, I’m not waiting for a fix and decided to get around the problem with a VC column for the same data – that seems to eliminate that platforms confusion about which format to apply. Still, I hope someone at AppSheet can fix this bug.

Hi @Lynn! Hi @Peter!

I’ve had one or more apps on my profile page for years now but I still have problems occasionally. Here’s a post I made about this kind of problem recently:

The error message tells me how to upgrade my account but not how to downgrade my app. I wonder if there is documentation about how to prevent this and/or how to deal with such a problem after it occurs (assuming that the prototyper wishes to stay on the free plan).

Hi @Kirk_Masden
I think now it is not quite as complicated as I made it and you can do it in fewer steps. I dont think anyone should be able to use your app without copying it. I’m not at my computer but will check my settings when I get a chance.

Thanks Lynn! The error message I got from AppSheet says I have several “users.” I must have done something to allow that (or failed to do something to prevent it) but this is new to me.

I need to review all of the options on my own but I posted here because I was hoping that someone might happen to know the answer.

Hi @Kirk_Masden
I dont seem to have any settings apart from “Make Public app” I have no "Users "

Thanks so much! My “Team Work” settings are the same:

I suspect the problem is with my security setting.

Mine has require sign in

Maybe you coud check mine and see if you can save anything?
https://www.appsheet.com/portfolio/129805 on the Trucks WF app?

This must have been my mistake. I’ll try again with this setting.

I was able to “see” your app but I probably didn’t become a “user” as seemed to have happened with my app., Thanks for the confirmation.

Have a great 2020!!!

Step #9.5 should be that you are required to fill something out here:

Otherwise your portfolio page won’t be accessible.

2 Likes