Monthly report not working

In my app I’ve set 2 reports 1 is a weekly report it grabs everything from one slice and sends it as a spreadsheet attachment, and a monthly that does the same but it’s only sometimes sending. I have it set to send on the last weekday of the month at 600pm but last night it did not send, looked at the logs I don’t see it even trying to send this is the second time this has happened, and I’m getting tired for double checking it each month end.

Have you already tried running the report from here?

Yes if I run it manual is runs perfectly every time.

did you check the time zone?

Yes the time zone is correct, I copied my weekly report and only changed the slice that data is pulled from and from weekly to monthly last week day of the month, other then that they are identical.

Is the application as deployd?, recently for my reports to work I had to pass the app to deployd, I think before they worked for free app

Yes it’s been deployed for a few months

Please contact support@appsheet.com for help with this.

I can investigate if you provide:

  1. Your account id
  2. The application name
  3. The report name
  4. Please go to https://www.appsheet.com/account/account#_tab_acctConfig and check the option that enables support access.
1 Like

Sorry for the delay in response.

Id: 1257619

Application name: Steadfast Caurier

Report name: Monthly report

I created a copy of the report and changed the time to see if it would send several minutes, and it did? I’m still unsure with why it didnt send on June 30.