Multiple issues with file access when editing an app owned by someone else

Having worked on multiple apps, utilizing different data sources, and owned by different people, I have constantly struggled with issues concerning utilizing external files to the app. I think that this is an important area that needs some attention and improvement from the Appsheet developers, or at least some documentation about how to work around these issues. I’ll try to layout some specific examples of issues I’ve encountered

  1. Adding a new data source
    Adding a new sheet in an existing workbook works fine. However when trying to add an entirely new data source, the process goes like this:

    • Add new table
    • -browse for more data-
      • New Data Source
    • confirm Leave Page
    • Select a data source (google in most of my cases)
    • Choose account to login (choose my google account)
    • confirm Allow
    • Screen returns to app editor Tables section, and absolutely nothing happens, no new data sources are available
  2. Specifying default app folder
    From Info->Properties->Default app folder. I can type anything in this field, as an editor or owner, but there is zero confirmation that it does anything. I feel like this field should also be a data source picker like in #1, where you first pick your service (google,microsoft,dropbox,smartsheet,etc), then choose a folder.
    If I type a folder name as an editor, is this specifying the folder in the owner’s google drive?

  3. Selecting workflow templates.
    I’ve had mixed success with this one. Some specific examples:

    • App owner shared app with me, along with entire google drive folder. I created template files in the shared folder. From a workflow, I opened the template file selector, and it automatically showed the shared folder, from which I could pick the files. All good so far. Some time later…something happened, and all of a sudden the file selector doesn’t default to the shared folder anymore. Also, the google popup selector doesn’t list shared files/folders in the main screen. You can still get to them, but it is not super obvious, you have to type their names into the search bar.
    • App owner shared app, along with some not-entirely-clear excel online and/or sharepoint folder. The owner had no problem selecting the template files, but if I tried to do it, it dead-ended immediately. At one point I was able to successfully directly edit the file’s path, as in going from “//folder//subfolder//file-v1.xslx” to “//folder//subfolder/file-v2.xslx”, but other times this didn’t even work, even copy and pasting the same file from the “body template” field to the “attachment template” field only worked some of the time.
  4. Save file workflows
    With the “file folder path” field, just like the “default app folder” from #2, there is no confirmation about this, and does it specify the path in the owner’s drive?
    I have one app where the default app folder has been set, and works fine for the automatic image saving (auto-created subfolder: “tablename_images”), but not for save file workflows.

Just wanted to write these issues down so there is a record for it. The only thing I’d really like an answer to right now would be #4; how can I get save file workflows to use the proper folder, optimally without having to ask the app owner to do very much? Other insights or descriptions of similar issues are welcome too.

2 Likes

#4 - When you don’t specify any folder with your Workflow, it will save the PDF into “Attachment” subfolder. That Subfolder you can find from Appsheet > Data > Appname-123456 > Attachment. If you use a formula for the folder name, it will add that subfolder if that folder name doesn’t exist when the PDF is created. The same will happen if you just type the folder name like “FolderName”. This will create that folder to Appsheet > Data > Appname-123456 > FolderName. This will happen when the first PDF is created.

How do I select a different data source in #2?
It took me a long time to understand that the data path was to my google drive, when the data source is on another account in Dropbox.
How is it done where files are saved to the data path in a specified data store?
The only Sources I have defined is the Dropbox one. How is Drive even available.

If I understood your request correctly… unfortunately you can save files only to your main data source.

1 Like

Is the main data source defined as Drive, unmutable?

If the account is created and used with your Dropbox account, it’s your main data source and you are only able to store files to your Dropbox account through the app.

1 Like