Need Your Creativity! Auto-reply to workflow emails

This seems simple, but I cannot conceptualize how to acheive this:

Client submits a form, creates new row in Google Sheets, triggers email to appropriate employee for review.

Perfect.

Now, said employee is away from the office and needs to utilize the Auto Reply feature in Microsoft Office… The FROM field of the triggered emails is always received as “noreply@appsheet.com”, even when overriding it to a local address in the workflow. Furthermore, according to Microsoft forums, it is not possible to configure “Reply ALL” when using the auto-reply feature…

So how can my employees communicate to their clients that they are out of office?

I am inclined to think that I could set up a table for the employee to submit an Out of Office request with a start and end date. Then somehow trigger AppSheet to review this table upon each client submission, before triggering both the client submission AND an out-of-office response…

Can anyone suggest how to accomplish above, or offer a better solution? All of your great minds are sincerely appreciated!

First you need to include your client email on your form using USEREMAIL() and put on on field

then on your workflow > Reply to declare the field of your Client email

The problem arises on the end of Microsoft Outlook

The workflow can be set up to have a message “appear” to be from any email address I choose, however, Outlook can only auto-reply to the ACTUAL sender, which is noreply@appsheet.com

In this example, the recipient Stephen@prophysique currntly has an Auto Reply turned on

Neither marissamcopp@gmail nor prophysiqueinc@gmail received his Auto Reply message…

Screenshot 2021-01-28 142517|469x264

Are you certain that you are not confusing these 2 options?

1 Like

Yes, I do believe I have everything set up properly, but certainly help me to double check:

Workflow Task: Send an Email to Coach upon Client Submission
To: [Coach Email Address]
[Client Email Address]

Reply To: [Client Email Address]
From Display: [Coach Email Address]

When the email is received by the coach (who has their auto-reply turned on) their Microsoft Outlook does not trigger an email to [Client Email Address]. I can only assume it is because the “actual” senders email is noreply@appsheet.com

image

Ok, just wanted to double check. In that case, I think this is also where my thoughts go:

Unless there is some setting you can edit in Outlook for this?